Object focus bug

[ more info in replies ]

I try to modify a newly created object. Instead, all instance of that object are modified, not just the recently created one.

How do I modify only the recently created object?


I believe index function takes a number

Hi per, actions placed directly below the “create object” will only modify the newly created object. Like the change animation action placed below it.

1 Like

Hi insein. That is the behaviour I expect, but I’ve come across something puzzling.

In the attached project, there is a line “Change the number of the animation of des”. This is executed immediately after automatic creation of “des” objects and should only affect those, but modifies the bottom row of manually created “des” objects as well. They end up purple, while they should be unique colors (see screenshot).

Removing the line In the section “Change the variable [hp] of grp orb…” under “At the beginning of the scene” fixes the problem. I don’t see why.

What am I missing?

Project files: Dropbox - per_test - Simplify your life

This is what the scene is supposed to look like, widh individual colors on the bottom row of “des” objects. With the offending line in place they are all purple:

This seems to be a bug. If you remove the variable line, it does work properly by not changing the animation of the last row. Oddly, it doesn’t matter which variable you set. If you add a subevent and move the action to it then it works but only if the other events aren’t a subevent. There’s something happening if the other events are subevents of a variable change.

doesn’t work correctly


I created a fresh project with only these events.

without the variable line

with the variable line

It doesn’t seem to be related to the variable action or the animation. I tried setting the opacity and it also seems to pick the objects that were already in the scene and increased the text value on each loop.



.I remember to had this problemy recently…
i solved it with an object variable,
Basically i made a created variable = 1 when object created, than for each object with created var = 1 do things than revert to created=0. But other objects (if in game) should start with created = 0

Is raw_des contained in the group des? Thats just object picking acting, since you are using raw_des in the repeat parameters, it is being picked.

What @Keith_1357 described tho indeed seems to be a bug.