OR condition makes GD crash.

When I try to move a condition into the OR block, it makes GD crash.

  1. add any condition to the event
  2. add an OR condition to the event
  3. move condition into the OR block

Can’t reproduce, even though I tried it like 20 times, so it is either random, or issue related to your computer. Maybe try reinstalling GD?

Just before made this post I have updated GD to latest version to make sure the bug is still there.
It crash GD all the time on my system :confused:
If I add or copy condition to OR block it works, no problem, but if I move a previously added condition, it makes GD crash immediately.

Just noticed, this problem happen only if you run a preview at least once before add Or block.
To make GD crash follow these steps:

  1. create a new project (or open an existing one)
  2. add an event
  3. add condition “At the beginning of the scene” to the event
  4. run preview
  5. exit preview
  6. add OR condition to the same event
  7. move “At the beginning of the scene” condition into Or block

GD should crash immediately as the condition is inside the Or block.

http://www.forum.compilgames.net/viewtopic.php?f=20&t=4960 :frowning:

This does not make a crash for me - Using latest version of GD on Windows 8. Lizard’s post also does not make GD crash for me. Weird. :astonished:

I don’t know why but on my PC I get this bug no matter what system I’m using. Windows7, Ubuntu 12.04, 14.04 fresh install, no matter, I experience this bug all the time, even in latest version 3.5.74 on Ubuntu 14.04 LTS just to mention.

I experienced that bug some days ago, but it’s not always easy to repeat to it in order to solve it. :wink:

No problem to repeat on my PC, it happens all the time with all the events no exception. Seriously.
All I have to do is to add an OR block, and move (drag 'n drop) any condition in to the block and that’s it, GD crashed, just sent an error report using the built in error reporter.
Is this really that rare on other machines, if so why? What could cause the problem that constant on my PC but not on others?
I mean it clearly independent from OS, as I get this crash even in fresh install OS :confused:
Every single time. but seems like others don’t.

I also have this exact same crashing problem.

Indeed, I’m able to reproduce the problem, but not to fix it.

Tried tracking callstack? To see which functions are getting called during crash and then check every for potential issues (null pointers, potential divide by 0, etc.)? This bug got me pretty hard today and lost over 10 minutes of work.

4ian already know where the bug come from, but it need to change a lot of thing to fix that bug.
To avoid the bug : when you want to drag a condition inside an OR/NOT/AND, drag it first to another event. Then, drag it directly to the OR/NOT/AND. :wink: