Panel Sprite Blurs even with Nearest Scale Mode (SOLVED)

I use panel sprites for platforms in my pixel platformer, but when I run the game with no antialiasing, they still appear blurred. Smooth the image is disabled, and I don’t know what I should do. I’m on the latest version of GDevelop.

1 Like

Try this maybe helps here
From properties

To the platform behaviour of your character check active round coordinates

1 Like

Looks like a cool game and looks like this solution will probably work!

Just wondering, what is that thing coming out of the player’s eye? Maybe it’s not coming out of the player’s eye, it might be something else, but when you have 8 x 8 pixels to work with, some stuff may not be the most clear to what it is.

That’s just the checkpoint flag behind the player. And thanks! Unfortunately the solution did not work, I’ll just have to tinker with the game resolution. And redo most of the UI.

1 Like