Physics automatism gravity bug

So before I encountered this bug, I was trying to slow down the fall speed of the player and I decided to do that by lowering down the gravity while playerObject is falling. Now I noticed that setting a gravity on the properties tab of playerObject is different from setting the gravity in the events page. If I’m not clear here is a demonstration:

Now I kinda hope I’m wrong about this bug because I don’t know of any other way to slow down fall speed without manipulating gravity :stuck_out_tongue:

*EDIT: please tell me if you don’t understand so I can clarify instead of just not replying to the thread :frowning:

EDIT2: sorry for the spam, I thought I was editing the original post instead of posting a reply :blush:

I’ve just checked the code for the action, it seems all right.
Could you please send me your game so that I can quickly reproduce and check the issue? :slight_smile:

These has two GD projects saved. One has the gravity on events which is bugged and the other has the gravity on player physics automatism which is the one that works.

So is this a bug or am I just being stupid?

Sorry, I didn’t managed to download the project and forgot to try again. But it is still not working, could you upload the project to a service like Dropbox or sent it to my mail ( ? :slight_smile:

email sent :slight_smile:

Ok, it was indeed a bug, a mistake from me. I’ve fixed it for the next version!

For now, you can avoid this bug by setting the gravity to 0 and apply a force using the physics engine with the same coordinates as the gravity : the gravity is just a force applied to all objects, so you can fake it by applying a force to all objects (you can use an object group by the way).
When the new version will be released, just removed these actions and add again the action changing the gravity.

Thanks for reporting this bug and sorry for the delay! :slight_smile:

Thank you for getting rid of it in the next version. Thanks for the workaround too. As long as there’s a workaround I’ll be content :slight_smile: