Pixel art blurring

Hey guys. I have a problem with the pixel art of my game. See

Image in editor:

Image in game

The original image is 32x32, I just resize it to 16x16. So far so good, and as you can see, the image in the editor is sharp. But when I start the game, it’s totally blurry and not at all sharp.

I was thinking that it could be something in the GD settings, or even some command line that was doing this, so I created another object, with another image that I didn’t have yet, and the result was the same. Edit: Just for detail, there is no effect on layers or objects

My configuration has always been this.

ps: When the new version, b117, came out, I saw that there was a new option “Round pixel when rendering…”, and I turned it on, but I didn’t see anything different, and at the same time I turned it off. Could it be that because I have done this, some configuration has been left in the code?


Are you applying some camera zoom, if that the case make sure the zoom is not a float value use Set camera zoom to round(cameraZoomValue)
About the round pixels when rendering, I checked out in one of my games and works fine but in some point of the game the screen start to create waves is really hard to tell if is because of that option checked, but one thing is for sure that never happen before that option were available.

I don’t use zoom. I use 352x192 internal resolution and 1920x1080 external resolution.

I never had a problem with that. I decided to test it with resolutions compatible with 1080, like 384x216, but it doesn’t matter.


I believe it is not something in the resolution. Because if it were, all the pixel art would be blurry.

Maybe the case is like this

I don’t know if that’s the case, my game blurs the image, which has never happened before.

Don’t know what Round Pixel while Rendering but looks useful for pixel art games. Does turning it on Fix the problem? And are you positioning sprites in a decimal and not integers?

Round pixel during rendering, it’s only been useful to me for an 8x8 game I’ve been making. As Ulises commented, Round pixel rendering creates a lot of waves and distorts objects a lot at certain points.Maybe there’s a rule for using it.

And check this too please.

I do not understand, sorry!

I mean, how are you positioning the sprites and objects? Are they in decimal/points? For example: 15.5 or 20.3
Or are you positioning them in integers? For example: just 15 instead of 15.5 or 20.

They keep moving, so there’s no way I can tell you. But initially I always leave it in integer numbers, because I use the grid.

The fact is, I never had a problem with it, my resolution was always the same, and objects were always placed at any location/point.

Is it a 9 Patch that you are using for Platforms?
You might wanna look into this too.

No, I use an object!

Found the BUG or error. It seems that now if I use a set internal resolution, as I do 352x192 the pixels are blurry, but if I use 3.5 (or higher) zoom which is the same thing (practically), it’s normal!

That is, if I put the resolution as in the image:

It doesn’t work anymore. I have to go back to using the camera’s zoom. The fact that I use the internal resolution (352x192) is because the base size of my rooms has these dimensions, it’s easier to keep a default of 16x16 pixels.

I still don’t know if this is a BUG or not. But that really didn’t happen before.

Are you testing in preview or export? Preview isn’t going to be a true 1:1 comparison to export full screen due to how it deals with the title bar.

Edit: oh wait. If your internal resolution is 352x192, it should have never have worked. That isn’t an integer scale resolution to 1080p. It should have always had some subpixel rendering.

I’m testing it in preview only, but always in full screen. Not if you make a difference.
I know it’s not a full format for 1080p. But rendering should work. However, even testing resolutions that scale to 1080p the same thing happens!

Preview fullscreen may be weird for that same reason.

I can’t give you a definite answer other than regardless of what you saw before, 192 height res should never had appeared correct, and should have always had subpixel rendering/distortion due to incorrect scaling.

I would definitely try a native resolution of 384x216 and do a full export to see how it ends up. I’ve tried 640x360 as recently as this weekend with my main project and I’m not getting any distortion.

Also ensure you dont have round coordinates enabled on the object behavior properties for any platformer character objects you have. Thats being removed for the project level setting. And there could be some weird conflicts.

What I find strange is that, because only the objects I resize (32x32 I leave to 16x16) do this and the others don’t. Because, if it was really the resolution’s fault, wouldn’t I have to get all my objects and sprites distorted?

However I will look for a resolution that adapts correctly to the size of my tiles.

Hmm. I might have misunderstood.

Are you resizing the assets, or the objects?

In green the original size, red is resized