Platform behaviors

There is something wrong with platform behaviors since the last update.

Normally, I would post my events, but the platform-related features were working as intended and I had not made any changes to them since way before the last update (no reason to, I’ve moved on to other features), so doubt the issue I’m experiencing will be solved by looking at events in this case. I have also tried the debugger already; variables and timers do seem to be working properly, so we can probably rule that out.

Alright so, I first noticed problems with the “waters” in my game. They all modify the platform behavior by reducing max speed and slightly increasing gravity along with a periodic ‘gentle’ upward force to simulate bobbing while the player is in a pool.

Once out of the pool, my default settings should be restored. But my player character was getting stuck in ‘water movement mode’ whether he was “wet” or not after stepping into a poison pool - actually, it started moving even slower than ‘water speed’ and seemed to have too much gravity as jumping was impossible.

I did finally fix that, but then springs started malfunctioning as well. :woman_facepalming: Springs temporarily change jump speed and gravity. The difference here is that the spring wasn’t launching the player up the way it’s supposed to, but once collision stopped, the normal settings returned - unlike the water situation.

Now my boost crystals aren’t working either. :crazy_face: One changes jump speed/gravity (yes, like springs, except crytals are consumable) and the other changes max speed. My ice platforms are also misbehaving; they temporarily increase max speed when the player is on them.

None of this was a problem until yesterday or the day before. Thank goodness I made a backup of my game before updating, but I think platform behavior events still need looking into.

Which is strange because it seems to me that a change has not been made on behaviors in general during the last update.
Wouldn’t that be a bad loading of the backup file?

There has been a modification on the pivot points, there is a message about it in the patch note.
The game engine don’t edit automatically the game file.
If a value of a parameter is accessible to the user in the editor, then it is the user who had change it.
The engine don’t touch these values without your action.

A little trick don’t use the copy/paste shortcut often , I’ve already had problems with it by selecting several events at once, it wasn’t pasting well and it set mess in my fonctionnal events.

1 Like

Do you mean that the copy I made of my original and am currently working from might have been corrupted?

That’s what is really strange. I was not working on events at all when things started going haywire. All I did was add another instance of my poison pool on a new level that I was designing and noticed the issue on preview. I was strictly working within the scene editor.

I should specify that some of the events in question are in functions and some are in external event sheets - they’re both acting up. But again, I have not made any changes to them recently. So maybe I need to try another copy of my original and see if it happens again.

Thank you for the tip about copy/paste, although I don’t see how that would cause the problem when the events weren’t touched. If I thought it was due to a mistake on my part or didn’t know how to achieve what I wanted, I would either try to work it out on my own or post screenshots for advice as I’ve done many times before.

Update: It must be that the copy is corrupted. The original seems to be working fine. I’m going to make another copy though and see if the same thing happens.

You can compare these files to see what has changed, I am interested to see this, which part has been edited.

I tried that a few times and the page keeps crashing.


I did end up changing a few things after the issues started in an attempt to fix it. I’m not sure how much can be learned from it in terms of what went wrong as it will probably seem like the attempts to fix it were the beginning of the problem, which they weren’t.

Aside from that there will be many differences between the original file and the one that was giving me problems; I had made several changes to the GUI, tried to experiment with the dialogue tree feature, and there were an assortment of tweaks to other features.

I’m 100% sure that no platform-related parameters were changed before things started malfunctioning. I added some visual timers for crystals, shields, and a new addition - but that didn’t entail editing jump speed, etc.

I tried that link in Firefox too and it gave me the message “a web page is slowing down your browser” before the whole thing stopped responding.

Do you know of another site for comparing code differences? I’m happy to put it up for comparison if there is a site that doesn’t crash my browsers and freeze my laptop, if only as a learning experience.

I suspect things started going south when I tried to place more than one poison pool on a new level scene because the events aren’t set up to accommodate multiple instances, nor is the potion that’s designed to get rid of this particular pool.

Your files must be too big maybe that’s what caused the crash.
No matter how many changes you’ve made, if you have made change so won’t see the difference. Then just forget this idea.

Ah, ok. Yeah, the latest version is something like 20K lines because I may have relied on groups too much before seeing how they bloat the code. I’ll forget about this then, thanks!