Player walljumping issue

poop - Made with Clipchamp

anyone know how to fix this problem? I don’t have the wall jump extension in btw

You’ve already posted about this in another thread, and in this one you haven’t explained what exactly the issue is, or how to replicate it. Please detail it better.

Others may not immediately understand what problem you can see - your character partially disappears into the wall and the camera being jerky are 2 potential issues. Clarify the problem.

I’ve moved it to the bug reports category, but you’ll have to explain it a lot better if you want it to be noticed.

Your collision mask is not centered so your character teleport inside the wall which gives its jump back.


I have confronted this same phenomenon, and I’d consider it as quite severe bug rather than a feature.

I made a small video describing the problem:

I think it’s quite common, that your character is not exactly in the middle of the image.

I guess most of the developers don’t want the wall climbing to occur, so the question is whether there is any fix coming to prevent this kind of behavior?

The workaround I have found is to disable “Default controls” from Platformer Character behavior, and set up controls manually:


By this way I can add “Player is on floor” condition to jump, which prevents the climbing. But by doing it like this I lose possibility to jump sustain time (at least I haven’t figure out, how to do that).

Thank you in advance!

Going by the video (which, btw, does an excellent job of concisely explaining the issue), this doesn’t appear to be a GDevelop bug, but a sprite set up issue.

It should be up to the game dev to ensure the game objects are fit for purpose. GDevelop is a tool, and it shouldn’t be the tool that gets modified to allow for a bad object setup.