Preview and Editor window shows Sad face at top-left corner of Screen

Can anyone help me with this? Recently, I’d been working on my game via an external USB device. Now, anytime I preview the game, that particular scene works well, but once I switch to another scene in the same game preview, the preview screen goes blank with a sad face at the top-left corner. Once I quit the app through the red X at the window bar, and go back to the editor, the scene where I made the preview window from also ends up with the sad face at the top-left corner of the editor. I opened the inspector tool and took a screenshot of it, in case it might help.

Once I close the scene and re-open it, this happens… The light objects refuse to show themselves in the editor, despite how they are clickable and despite how the lighting layer is enabled.

I restarted gdevelop and everything was normal for a while, until I ran another preview and the same thing happened again. This is the third time this morning.

Here’s my PC’s specs, in case if that’s useful… Ram: 12GB chipset: Intel Corei5-4570 GPU: Intel HD 4600
Windows 10

I previewed it again, and the lights failed to render in game. This is the error message.

“webgl” is a renderer, some sort of software used to draw graphics on your computer. It seems to be missing or disabled in your environment.
Can you try other projects, the lights example project for instance, and check if/how it works? You can try it in the GDevelop app and in the Web browsers you use, maybe it’ll yield a different result.

Yeah, I tried opening other projects and it works.
Even the same game that the issue came from. It works there. The only time the error pops up is whenever I go to a particular scene over and over. And that problem only works in the editor and the preview.
It doesn’t happen Via LAN/WiFi and it was happening to the pc export of the game, i managed to fix the latter by uninstalling and reinstalling the game.
I proceeded to testing the same PC build on another computer and the error never shows up.

I also decided to run gdevelop on another pc and try to repeat the same process but it worked fine.

I decided to reinstall the software on my original pc, but it still didn’t get fixed. It kept giving me the webgl error.

Maybe you have too many objects on the scene, and calculating all the shadows somehow exceeds the capabilities of your GPU. :person_shrugging:
How many instances are there on the scene?
You can try duplicating the scene, and then changing and deleting stuff until you figure out what’s going on.

I’ll give that a try.