Preview of native projects always fails - Ubuntu

Hi. I’ve recently installed Gdevelop from the PPA and speeded through the two step-by-step tutorials which take the HTML5 platform as an example without any major hickups. The IDE ran well and the Preview feature worked every time.

However, when I tried to preview a native project, be it a bundled example or a completely empty project I was greeted with a dialog:

The mentioned textfile was empty every time but I’m attaching it anyway in case the two bytes are actually somehow significant - . The system was Ubuntu 14.04 x86_64 with 3.14.1-031401-generic kernel.LatestCompilationOutput.txt (2 Bytes)

Then I tried to reproduce this in a clean install of 64bit Xubuntu 14.04 in VMWare Player and it still refused to compile any native project with the same error dialog. This time, however, the LatestCompilationOutput.txt file isn’t empty.latestcompilationoutput.txt (1.08 KB)

I hope I didn’t miss something important in the docs; at least Google search I performed didn’t suggest so.

Ok, I see I overlooked the compile option hidden in the menu, confused by different steps with different platforms. So the games do actually compile. The preview button still gives the error, nevertheless.

Do you have the package build-essential installed?

On the main system, yes, version 11.6. On the testing one in the virtual PC it is not installed.

i have the same problem, i cant preview native games.
im using linux mint 17.1

this is the text of LatestCompilationOutput.txt