Project file has been saved as empty

I have no idea of what happened, and if anyone, and I mean ANYONE knows a way to fix this, then PLEASE tell me!

I tried opening the project for my game today, and this message appeared:


I tried opening another project, and it worked. So, I tried opening the .json in the notepad just to check, and well…

Empty. Completely empty. I am going NUTS looking for a way to recover it!
And there isn’t a .json.autosave file anywhere in the project location…

And if in the end, there isn’t anyway to recover it, may this serve as a lesson to always make backups, I guess??? I don’t know I’m scared

Unless it’s a cloud project, there’s no way to restore that file via GDevelop itself.

If your computer is running Windows 8 or newer and has file versioning turned on, you might be able to restore to a previous version that way.

Otherwise in the future I’d recommend using github desktop and storing your project on Github. How to backup and maintain your project using GitHub and GitHub Desktop - GDevelop documentation

1 Like