Project suddenly Json 0 bytes!

many days worked for a small project with
B95 : [Win 32 bits]

i noticed that sometimes when i opened the project i had long waiting periods and i closed the gdevelop and then start over and the open project worked fine.

my Last move was to open the project and then Export (android,pc,mac,linux…) with everything ok

the next open (after many many hours) gave me the hit!:

“The project file appears to be malformed, but an autosave file exists (backup made automatically by GDevelop). Would you like to try to load it instead?”

i had disabled the auto-backup and no other made…

The Json = 0 bytes!!!

Please, is it possible to send me the {soko2epal.json} file (if it somewhere stored at you) when i made the Export and accessed GDevelop online services (through my free account)?

best wishes!

Sorry, once the file is gone, it’s gone. What is uploaded to the Build Service is a vesion where the json file has been converted to real javascript code, and you cannot reverse that.

Always remember to make backups of your projects!

i understand the limited case of a malfunction οn project opening as a bug of the gdevelop on saving, but… to zero bytes? i think that such a serious "decision"… and must have a “safety net” into gdevelop other than to always backup…

There is autosave for that but you disabled it.

I’ve seen a potential bug fix for it, 14hours ago.
But anyway you should always do multiple copy of your project.
I’ve had a lot of files loss on software so I got into the habit of making manual copies very often.

The autosave is good think to enable it, but the safe way is always to copy manually yourself the file for a backup.

Have you press save between openning the project and export, or after the export ?
Because the game file isn’t save when you do an export.

Also the autosave is cool because when you do an preview the autosave is updated with the version of your project before the preview.

but if the bug is on the save code is always open a possibility to destroy the .json and also probably to unstable all the autosave or external backups…

the deletion of .json content (0 bytes) it’s a strike! without logic
imagine to work on a .docx and suddenly after a save and close you get 0 bytes file…

As long as you keep backups, you can recover your game, and we can investigate what’s going on, why the file gets deleted, what happens exactly and how to fix it. But without a backup, there’s not much we can do…

Of course, before opening a backup, you should make a backup of the file, to make sure you have a copy in safety.

That being said, this is the third report I see about an empty json file. It’s about as bad as a GDevelop bug could get. :confused:

The project go to 0 bytes because the writing in the file was interrupt.
I afraid this can be one million of reason.

@Gruk can you collect all reports that you have seen about this issue and maybe add a post on github with it?

Also 3 reports on thousands users isn’t very relevant for understand where is the potential bug or issue with the system.
More information is needed to conduct an investigation.

1 Like

That happens to me a lot. That’s why I always backup everything I work on or keep a copy of it online (via git and a github repo for example)

…the blow was unexpected and without any warning, save…satisfied… sleep …wake up …open and 0… like me i guess…


I don’t want to be ungrateful to the development team of GDevelop

I am very happy with their offer of a great free tool like GDevelop

best wishes!

i had keep an .apk file of the final project
and if i could uploaded to playstore i will have a solution
the file is the same version with the allready plublished and google refused to upload…

is it possible for you to edit the version of. apk but keep the pre-signed of the GDevelop online services made through my free subscription?