"Quit the game" action no longer works

Since update 5.3.186(maybe before, I’m not sure) the quit game action does nothing. I’ve tried triggering it several ways in a new project and in the online editor. I haven’t exported a project to try it that way, but either way it worked in preview mode up until very recently.

You can’t “quit” the game in a browser, because it makes no sense (Where would it bring you? To a empty tab?)

About the quit game not working. No, it works on the latest 5.3.186 release, check this video.

You’re absolutely right, that was a pretty stupid thing I said about the browser preview, but regardless doesn’t change the fact that no, it doesn’t work in the latest 5.3.186 release, check this video.

It does. Maybe it’s your keyboard emulator/simulator that’s not working correctly? Here’s it working using the Window 10 onscreen keyboard:


(Sorry, managed to chop most of the bottom keys - you can just make the pressing of the left ALT ket, just below the X & C keys).

It must be my computer, I guess. I also realized the Fullscreen action doesn’t work for me either. Tried both in a new project with buttons, timers, mouse clicks and keys pressed and nothing works. Except, occasionally, the green button (which should quit the game) activates fullscreen. Here’s another video. This is bizarre.

Oh and the onscreen keyboard I was using in the first video is just the default windows 11 onscreen keyboard.

Maybe that’s the issue? I’m running on Windows 10.

Man. Any ideas on what I can do to fix it?

Find a windows 10 machine and compile your project there?

Or, if you can get your project into the online editor, possibly use that?

Otherwise, as you’ve already flagged this as a GDevelop bug, I can’t think of anything else. It may just be a case of waiting until a GDevelop developer spots this and works out a fix.

1 Like