Rona Times - Playable Demo

Play Online:

Latest Info:

I’ve been working on this for a couple of weeks now. It was inspired after talking to a few people and finding out that the old game “Maniac Mansion” is virtually unknown to the younger generation. I won’t go into Maniac Mansion, as there’s enough about it on the internet; only to say that if you haven’t played it, you should.

Rona Times takes place in - you guessed it: Corona Times. These are strange and unusual times: people may not talk to you if you aren’t wearing a mask, and that’s just the beginning.

In Rona Times, you have a button to interact with objects. You can also find items. Items you find can be equipped as well as used. The way the story proceeds depends on what items you use in different circumstances.

This game is different from Maniac Mansion in one important way: I’ve added a little extra. There is also a stat group styled in what I call the “Inner Demons” brand: you have measurable quantities of your virtues: Will, Patience, Courage, and Guts.

The challenge is to find what items to equip/use in what circumstances while having the virtues necessary to complete the task. For instance: You may investigate an object and see nothing. You may use a magnifying glass to see extra detail, but only if you have the patience.


*on screen controls
*save and load
*HUD display
*Popup menu
*Open ended game play
*Randomly generated forest scene

Known bugs:

*There are certain details a player could miss if you do everything in a certain order. I need to add some more scene counters to control what is displayed and when.
*a couple of graphical bugs on the town map where I’m missing go behind graphics
*occasionally a music file misplays. I’m not sure where this ones coming from.
*I tried to include sound effects for all the npc interactions, but I missed a few. I need to go in and fix all those, maybe with some new sound effects.*Hopefully fixed
*this is only the first level, or area. There is a gate leading to the next scene, but the next scene is empty save for global objects (player, gui, items). If you save there you’ll get stuck. *Second area is added

This should be considered as just a short demo for debugging. Suggestions and constructive criticisms are always welcomed.

Created a walkthrough

Maniac Mansion: this reminds me old time on PC, Amiga, C64,etc.!

P.S: after loading HTML game , the display stays desperately grey!
Others do have the same problem?

There appears to be some problem with the screen resolution.

Take your browser out of full screen mode and resize the window. That worked for me.

I made a few updates to this and experienced a strange bug trying to export it.

I was able to export fine to android.
I was able to html export fine.

I tried to export to mac/windows/linux, and the export fails. It throws an error saying to check my internet connection, which is just silly, and then it recommends trying later, which I think is sound advice.

I then did an export to gdevelop, which worked fine.

I still can’t do any pc exports, so it’s kind of odd. If the situation doesn’t resolve itself in a day or two, I’ll make a bug report.

Anyways, back on topic.

The latest version I fixed a few bugs, added some sounds, and began constructing stage 2, which I call “Ronery Forest.”

I maybe went a bit over the top with the forest. It’s a randomly generated landscape with trees, rocks, and plants placed here and there based on RNG. Use your items to explore the landscape and see what you can find.

I haven’t made a way to die yet. The difficulty needs some adjustments.

You may encounter mythological creatures, or even befriend some if you have the character stats. Different items used on different objects will yield different results. It’s all very random. I don’t know what will happen, I only know what could happen.

The thing with the screen resolution is still there, but it works fine in windowed browser mode. I’m almost positive there’s a way to fix it but I have yet to discover it.

Here’s the link to the gdevelop web upload:

If any admins happen upon this and want to check the logs and see what went wrong, that would be great, if not, I’m not super pressed with it, I’ll make an official bug report later.

Thanks for everything. Hope everyone is well.

As i could say in a recent post (GD french forum section), you must have some ads in your game and actually (i don"t know why), the display is grey during lauching the game. The Reason could be that the game is waiting Ads which never come!
A solution (workaround) for the moment would be to include an event which, after a few seconds, go to the scene of game.
So, there is actually a great issue with Ads!

This looks like the beginnings of a cool RPG game but there are some issues getting it started. It’s true that if you resize the browser enough, you can just about see the NEW GAME option to start the game. I don’t know if you have the “update resolution…” option checked in the game properties?

Also, how do I get out of the first room or is the demo limited to that room?

Thanks! It corrected my problem.

1 Like

It’s an idea for something to check, but yes the update resolution is checked. And with screen size of only 400X300 it seems to me it shouldn’t have a problem displaying on any modern device.

To leave grandma’s house you have to equip your boots. Do you think grandma’s gonna let you out of the house with no shoes on?

I wrote a walkthrough for the first stage. You can find it HERE

Also, you can hide the message area at any time by clicking/pressing it.

Great, I’ll have another try in a minute… Will read that walkthrough only if I get stuck lol…

Just looking at the properties I wonder if it’s the “Change height to fit the screen” which is causing issues with the browser. Maybe you need to do “Change width” instead? I believe Change Width is the default mode.

The image that I pasted above is the entire game area that I can see on screen. Are there any buttons missing because I don’t know how to search things. I can view them with the target but i don’t think that’s the same as searching them?

Yes, you search/interact with objects by using the bullseye.

Once you’ve found an items you can equip it by

  1. press/click menu
  2. press/click the item you want to equip
  3. press/click menu again to close menu
  4. once your item is equipped, you will see an icon for the item on screen. you can press/click this icon to ‘use’ your item.

I switched the settings to fit horizontal:

advise if this fixes your issue and i’ll edit the main post to include it.

1 Like

Ok got it now. I finally equipped the boots and went outside :smile:

Yes, the horizontal setting fixed the issue for me. Now the browser doesn’t require resize. I’m going to play more later. This seems like a very cool game. The style reminds me a bit of the old Final Fantasy.

Some feedback about the movement controls. As it’s my natural inclination to use keyboard to play, I noticed the character animation doesn’t change when the arrow keys are pressed, it only changes when the on-screen controls are pressed. Easy fix I think. And it might also be worth considering an option to Hide the on-screen controls to accommodate players who are using the keyboard (to make more of the game area visible).

This is a valid point. I tend to focus more on mobile gaming as I feel it’s a larger market, but I definitely need to fix those. It should as you say be an easy fix, just a matter of adding an “OR” condition to the appropriate events with the key press, but rather than doing a quick update just for the animations, I’ll plan a larger update to fix all the control issues, and include hiding the on screen controls as well as full keyboard controls - have key presses for not just directional movement but also equipping items and for using items when equipped.

I had already thought about mapping keys for all the controls, but I hadn’t thought of hiding the on screen controls. Thank you for your input.

1 Like

I just replayed the game and running into a few bugs to report… I read the walkthrough. Now when I go to doctors office, the patient takes the glass of water first time and it doesn’t add 3 patience. This means that I can’t get the mask. Went to the shop to try buy patience (trading courage) but it wouldn’t add any patience even though it said “your patience has increased by 1”. I saved the game then restarted but it doesn’t fix it. Seems I can’t buy patience, or get any from the doctors office so I don’t think I’m able to progress any further in the game at the moment? Maybe I’m missing something but if not then hopefully the bug report will be helpful. The game is coming together well. Very nice little universe you created there!

1 Like

Thanks for the feedback. I’ve played through it a few times myself, but it seems like a few bugs always slip through.

I was unable to reproduce the bug in the doctor’s office with patient zero. When I tried, it worked fine. I’m curious what version are you playing and where did you download/stream it from?

I did encounter the bug in the shop. Just a variable I missed editing after copy and pasting. I’ve fixed that one. Here’s a quick patched version that’ll hopefully allow you to proceed further.

The version I’m testing/playing is available HERE

I played the version that was Latest Version in the first post through the browser. When I try the new version that you linked there’s no way to load the last game. Also the screen seems to be resized again (only the up control is visible unless I resize browser.)


I’m still puzzled on the patient zero bug. Until I can reproduce I’ve no way to fix it.

The screen resize thing is something I need to pay more attention to.

When I export to mobile, I use the stretch to vertical, as stretch to horizontal doesn’t display in a playable manner on my phone. Unfortunately I’m forgetful and didn’t switch it over. I apologize for misleading you.

As for the save thing: to my understanding, the save data saves in browser data, kind of like a cookie? And the cookies are linked to a file/url. As far as I know there’s no way to transfer save data between games, unless you went in and edited the cookie manually. Maybe if both of the games were at the same url the data would persist?

There’s also a good possibility I’m wrong; I don’t really know how the save works on the engine side, it just seems I saw something about browser data somewhere… so if I’m wrong hopefully someone will correct me.

Here’s another patched update. No word on the patient zero bug but the store should be working. In this version I exported with the option “No changes to screen size.” I’ve not tried this export before but maybe it will solve the display issues :slight_smile:

Thanks again for trying. I’ll keep cracking away at it until I get it right. I’ve been working on a different project with a partner lately: A platformer inspired by the old classics like metroid, mm, and castlevania. I’ve got the basic controls for the character and now working on a menu for equipping/unequipping items, save/load, etc. After that I’ll need to set up conditions and actions for the item/status effects and then pass it off to my partner to make the levels and enemies; then I’ll put a bit more work into Rona Times. I predict another week or two before I have any substantial time to put in to it.

I can’t remember the exact series of events but I did initially just talk to the first character (not the patient at first), then i might have gone back out, then back in, clicked the desk near the patient several times to look at the magazines, and then talked to patient. Something like that I think. Basically I interacted with a few other things in various places in the room (possibly including the sink), before I eventually talked to the patient.

My guess is that you might have a condition or variable attached to the code where you give points to player after giving water to patient. I some how triggered that condition or switched the variable before points were given so now the condition isn’t being triggered to give points.
I couldn’t really make a guess as to what triggered the shop bug though.

The entire interaction with patient zero is handled with a scene variable, so if you save and load you should be able to attempt it again.

According to my search:
There are 3 collision items where patientzero is found, and 12 events where patientzero is mentioned
Those 3 items are “doctorsPatient” “doctorsP0GetWater” and “DoctorsP1WashHands”

Each of these items has 6 conditions, Variable patientZero 0-5
an action to change the value of patientZero only changes 5 times.

I’m still unable to reproduce or eliminate this bug. If anyone has an idea of what it could be or how to eliminate it i’d appreciate any suggestions…

The shop bug was just a typo and was fairly easy to find and fix.

Just finished updating this to include keyboard controls.

The update fixes the animation when using the keyboard to move the character, and adds a whole new layer of control for the player.

To access the new controls, press “H” for ‘hide’ the on screen controls.
To bring back the on screen controls, use “G” for “gui”
Save data: F1
End game Q
Number keys 1-0: equip/use item (if you have the item)
control(left/right): investigate/search
return: close message prompt

I’ve played through it twice with the update, and so far have had no problems getting through the town and collecting all the items, but I did find a few input bugs from the new system. All the input bugs from the new controls I’ve found have been corrected but there are problably more.

Still no luck with the ‘patient zero’ bug. I’ve had a friend play through it and he was also able to get past this area with no issues, so I’m really puzzled at this bug.

The second level (ronery forest) is there, but it still largely incomplete, and there’s no way out, so if you make it to stage 2, don’t save unless you want to get stuck there.