Scene Editor Window Black Screen With "sad face" (broken image) mini icon

I am using GDevelop on a (slightly older, but still very fast) laptop with (yes you guessed it, Intel HD gfx).

GDevelop often starts up fine though, and loads projects, but after switching to/from the scene editor window, eventually GDevelop will break and just show a black screen with a little “sad face” at the top left, similar to a ‘broken image’ link on a website.

What eventually happens… A black screen, which can only be resolved by quitting GDevelop, and reloading it. I’d upload images of it working, but new users can only add one image.

Sometimes GDevelop loads with the black screen from the getgo, and I have to quit/restart a few times to get it to work properly.

Sadly, Intel stopped updating their graphics drivers in 2021, so although I have the ‘latest’, they’re a year old because it’s still running Win7 x64. Unfortunately for GDevelop, I have zero graphical problems in any other games, and I use this laptop for gaming a LOT in HTML5, DirectX, OpenGL as well as retro gaming through DosBox. I’ve also tested Godot, Construct2, AppGameKit, Scratch and several other engines and none of them have any graphical problems at all. Only GDevelop does this.

I’m new to the app, and I loved my experience so far, but sadly, I’m gonna have to switch to Godot which seems a waaaay higher learning curve, but doesn’t go blank on me all the time. I hope this helps the devs to fix GDevelop cos it’s an AMAZING app, and I was able to get something running really quickly.

If you wish to reply to this with “Upgrade to Windows 10” or “buy a new laptop”, then please don’t reply, that’s not helpful for just this one little issue, thanks.

Intel Core i5 - quad core @ 3GHz
RAM: 8Gb
HDD: 256Gb SDD
Video: Intel HD 4000 series
OS: Windows 7 Pro x64

:wave: Hi and welcome here :slight_smile:

Please confirm which exact driver version you’re using.

Maybe some features aren’t supported by your chipset/drivers.
You can investigate by starting with a blank project and testing features individually.
That won’t fix the issue, but you’ll know which features to avoid. :person_shrugging:

Also, pressing ctrl-shift-i and checking the Console might reveal some interesting error messages.

Hi There!
Thanks for responding. The Intel Driver version is I upgraded it yesterday while troubleshooting this issue. It’s listed on the Intel Website as the very last version available for this graphics card. It’s not horribly out of date, but is a year old. Also ran dxwebsetup and checked dxdiag… All DX components are fine.

Thanks for the Ctrl+Shft+i hint, I opened it up, and as I suspected, GDevelop gets the good old “context lost” error. I used to get this ALL the time when I was doing OpenGL development back in the 90s. Often it was down to timing, but it was early days back then… I do a lot of Alt+Tabbing to check Twitter while playing games, and don’t get a Context Lost error elsewhere.

Here’s what the console says:


With regards to avoiding ‘features’. It happens on all projects, no matter the complexity. My little demo project literally just has two images and a shapedrawer, plus some very basic logic for keypresses etc. If I avoid any of those, it’s going to be hard to make a game :wink: Seriously, though, I think GD is trying to do something like reserve multiple contexts on the same handle, or setting a new one up before the old one has finished deconstructing, so badness occurs when the canvas is being allocated during a page-flip or window-switch.


btw, seems unrelated, but I get this error too…


Fresh installation. Checked inside the asar file, and there’s no file with that name in that folder. Unsure if that’s pertinent or not.


Yes, these warnings are always there.
Thanks for confirming the details.

If you’re not using any particular feature when the issue occurs, all I can suggest is to uninstall/reinstall GDevelop, the drivers or Windows entirely.
Unfortunately, if your GPU has some WebGL issue with your current driver, which I guess is the issue here, there’s nothing the devs can do about it. GDevelop is built on components built by other people (Chromium and PixiJS, mainly, I guess), and their updates cause more and more hardware to become incompatible.
Windows 7 is outdated, whether you like it or not. :person_shrugging:

You can try the online version of GDevelop, maybe it’ll work better for you, but you’ll find it has big limitations.

Luckily for you, all the other engines you tried worked fine, so you’ll be able to proceed with your game creation. :slight_smile:

Thanks for the response once again,
Aye, Windows 7 may be outdated, but to date everything that’s not explicitly created for Win10 seems to work. The kids and I play a LOT of WebGL / HTML5 games, including some really taxing ones on CrazyGames… None of them experience any issues, and are usually pretty responsive, considering this is an Intel HD graphics chip.

It’s a real shame I can’t continue with GD, I was absolutely loving it. I’ve never clicked into an engine as quickly as this, and I’m so impressed with everything it can do. As I mentioned, I’ve tried reinstalling drivers, DX and GD, but to no avail. For some reason, after a random number of page-flips when GD is attempting to redraw the scene in the editor (and ONLY that one panel, never the preview or running games), it just gets a Context error.

Like you, I’d write it off as an incompatibility with GLes, WebGL or similar, excepting that it only happens in one app, and even when it’s doing something really non-taxing like displaying a single icon, while other apps using the same tech can render huge 3d worlds with multiple players onscreen at once.

Ho hum… Maybe I’ll try older versions and see if there was something that broke at some point, or wait for an update.

Thanks again for your time and consideration. GD is AWESOME and I hope many more people come to appreciate it!



GDevelop uses pixi.js for canvas rendering. If your setup yields errors, try submitting the details of your issue with it’s maintainers. They are the ones who can fix it, not us.