“Should finish soon”


I don’t know anything about programming, and I’m not trying to learn, which is why I was hoping GDevelop would be an easy enough tool to use. So far, it’s been great. I’m actually using the program to develop a point-and-click style “game” that I want to use as a walking tour of a museum that I work with. I’ve created a demo, and it seems to work just fine in the preview. But I tried exporting, and it says “should finish soon”. And it has for 14 hours now. I’m not sure what I need to do to fix this. I’ve tried to find answers that already existed in the forum, but I either didn’t understand them or they didn’t work. To be clear, this is on the last step of the export process. I’ve chosen the Windows/macOS/Linux option (not the manual one), and wanted it put into a zip file for Mac and PC. It did the first steps fine, but on the last step it never finishes. When I close out, and click “See all my builds”, it still says the same thing. Any ideas on how to fix this? Please keep in mind I don’t have a very large range of knowledge on this stuff, so I may need walker through a solution.

You should try doing local builds then instead of uploading and see if you get the same problem

What is the size of your .json file? (game project file)

Go to the game properties and make sure you fill everything (name, version, icons, etc) and clear the unused/invalid resources (right-click in the resources list). Then try again!
And update to beta 93 if you haven’t done so yet.