[SOLVED]ATI mesa problem in ubuntu 12.10

with ubuntu 12.10 my graphic drivers not have proprietary drivers, game develop have problem with mesa driver, serious problem :astonished: this problem is with mesa ati

i stop to programming, my pc not is compatible with gd :frowning: , i wait for buy new :stuck_out_tongue:
i have learn that gd go only with proprietary drivers, serious problem
good luck with your program

solved with old proprietary driver ati in ubuntu 12.10:

sudo add-apt-repository ppa:makson96/fglrx sudo apt-get update sudo apt-get upgrade sudo apt-get install fglrx-legacy
this ppa is good for the ati 2xxx 4xxx that not is supported in ubuntu 12.10
but is not solution remember, the open graphic card driver go on all old pc, the solution is in program comunication with mesa

It is always better to use the latest up to date graphics driver, or on Linux proprietary driver if they are better than the others.
GD does not use anything special, the games are simply rendered using OpenGL. If a driver is badly written and/or has bugs, GD may be unable to work, but I cannot do anything ( And in this case, it is likely that other games or programs using graphics won’t work correctly ).
Anyway, thanks for reporting that it is better to use the proprietary drivers, it may help someone else.

( Please, try to use capitals letter and do not forget period ( . ) at the end of your sentences :slight_smile: )

i have found that mesa ati with old pc on debian go, not is specific problem of mesa.
the video card: Radeon Xpress 200M
and drivers xorg-xserver-video-ati-1.6 32bit
anyway, i chech the driver of other pc
!!!Warning!!! the ppa downgrade xorg for install drivers ati. I have purge ppa for this.
I try with ne kernel, if compil game go is good, i post the result.

1 I have istalled fedora 17 64bit (non proprietary drivers)
2 i have see (ldd) and istalled dependencies (yum install)
good bye ubuntu