[SOLVED][BUG] Send a request to a web page - Android - no response or error [object ProgressEvent]

I did a little investigation. Send a request to a web page works on windows Preview, but not exported to Android. On android there is no server response or there is an error [object ProgressEvent]. Of course I have a properly configured ssl server and am using the url from https.
After testing various versions, the last working version is 102. This includes the old and new style of using Send a request. Version 106 is also bugged. Can anyone confirm my findings?

All the requests sent on Android devices must be over a secure protocol https, check if you are doing it like Send to “https://blahbla.com/?param=x&param=y” plus if the process of the data is in a server of your control include Headers for cross domain.
Hope this helps.

Yes, I can confirm it. I have tested these events on multiple android phones and the latest android versions only accept https.

I’m talking about it here

Guys read with understanding what I wrote. It is obvious that you need to use https (SSL) on android. I wrote that despite using SSL, this does not work if we export the .apk from a version newer than 102. Thus, there is a bug in the latest versions of GD.

Salvatore, you wrote that you agree with me, that it works for you. I wrote that it doesn’t work :wink: Can you export your Android application from the latest GD and check if “Send a request” works on Android 10 or newer?

There’s a bug, or syntax has changed?
Please provide a screenshot of the related actions.

If the syntax changed, it wouldn’t work on windows either :wink:
I made a project with new and old “Send a request”.
Take a look:

If you export this project to .apk from GD 102,
everything will work on Android 10 and above.
If you do this with a GD 103 or later, it won’t work.

Hmm, why do you use an obsolete request action? If you can’t find it in the action list, don’t use it. :wink:
Also, which part of “use https” wasn’t clear?

I am using the outdated request action, because I started the project in the GD 9x version, only after it stopped working I started looking for the reasons. GD did not inform me that something was outdated in my project when the new “Request a web” implementation was introduced. However, even when the new implementation entered, the old one still worked, it works under Windows until today, under the new Android version up to the GD102 version. There are two new and old style requests in the project I have attached. Both do not work on Android 10 and above, as of GD 103.

I can’t click through the whole project every new GD release and check if the implementation has changed :wink:

“Also, which part of” use https “wasn’t clear?”

Everything is clear to me, but it doesn’t work, in my opinion, due to a backward error in GD (regression).

Why in the screenshot you changed https to http ???
In my project, both requests are https.

Have you exported this Android project from a version newer than GD102? It worked on android 10?

Gruk, I get the feeling you didn’t understand what I wrote about in this bug report.

I’m not saying you should check all actions after each update. But if you know it’s outdated, because you found a newer one, stop using the old one, that’s just asking for trouble.

I did not change https to http, I just opened your project…
I opened the autosave, looks like I shouldn’t have.

I’m not used to network actions, so I’m not the most qualified to help. But you’re stuck with me for now. :stuck_out_tongue:

Did you try with another website known to work, or only your own?

I’m on Android 9.

Thank you Gruk.

Now I will be using the new action. It’s just like that in this test project I used both actions to show that it works on windows, and on the new Android it doesn’t work.

I wonder how to check if I have any other old actions in the project?

Yes, I tested it on other sites.

It is possible that there was http in autosave because I tested different options.

Yes, if you have Android 9, you cannot confirm or deny it.

Ok, we’ll wait for someone to speak up who has android 10/11.

Can you ask 4ian, maybe he can check it quickly?

I tested on two phones with Android 10 and one with Android 11 and this emulator:

Thanks for the details.
I have now forwarded the issue to the devs.

Have you tried network preview (debugger icon) on your Android devices, by the way?

Strange, when I run Network Preview with GD102, I have an error: [object ProgressEvent]. I checked on Samsung and Google Browser on Android 10.

The exported to .apk works as I wrote earlier.

The question is whether my connection on the local network (Phone -> Computer), which is not SSL compatible, is not a problem now?

I’m not sure how local network can’t be ssl-friendly, but obviously, that would break the concept of end-to-end…

Do we have feedback from the Devs ?

Dev confirmed that httpS is required.
Try another network to confirm that your own network is the issue here.

Thanks Gruk, but:

I am devastated by the level of conversation.
Has anyone checked it and can answer:
Yes, I confirm, it doesn’t work either
No, everything works for me, I did this and this …

Has anyone fired this example of mine and checked it on different versions of GD? What are the test results?

Hello again, I don’t know if this can help you but hey there it goes
I wonder what url or domain are you sending the request to?

  • It has SSL, the data collection is done in PHP or in what language.

  • When making the request, it is sent as POST with adequate encryption.

  • Have you checked that the .htaccess of the web allows CRUD requests?

  • The request headers should look something like this
    Date: Sat, 27 Mar 2021 21:44:18 GMT
    Server: Apache
    Access-Control-Allow-Origin: *

I can confirm that sending request from Android to a website is accepted ok.
I don’t have an Android device but i’ve tested in Bluestacks and LDPlayer 4 and is working good.

Can you upload the project you tested?
Have you tested my project I attached?

Problem solved. The problem was the CORS configuration on the server. Strange, because it has always been required, but everything worked, only from the GD-103 version exported to Android stopped working. This lulled my vigilance and pointed to some changes / bugs in the GD-103 version, because it should not work earlier either :wink: