[Solved] Bug suspicion : resource bar object (separated units)

Hi! As I was requested, I moved the issue to a new thread.

The bug :
the action “change the maximum value” when dealing with a resource bar (separated units) doesn’t seem to work in the code.

When I try to modify this number in the code, it doesn’t work.

Here is my code :

image1403×112 8.39 KB

Here is the Editor of the Resource Bar :

and here is what I see in the preview :

Conclusion : the “change the value” line works but the “change the maximum value” doesn’t seem to work.

To reproduce the issue, simply create an object Resource Bar (separated units) and try to modify the maximum value through the code.


1 Like

I’m sorry to reply to my own thread but is there something I can do about that? Do you guys have the same problem?

I spoke with someone. It’s being looked into. I’m not aware of a workaround for changing the value at runtime.

I did confirm that the MaxValue is changed, because I cannot increase the value above the new MaxValue.
The issue has something to do with drawing the unfilled hearts


Many thanks for your help!

1 Like

Hey there,
sry to little necro.
Has this been fixed in the current ver?
Cos it looks like i’ve the same problem.

These type of resource bars are sorta easy to make, so why not make your own?

Its far more performance friendly too!

I’ve no problem with it.
But when you have a tool, you expect it to work.
.i can wait, make resource bar usually is not a priority

1 Like

I just tested this, and its legit broken no matter what

Yep, i figured it, after i spent a good hour lookin for mistakes in my whole project.

Honestly, these bars are way more trouble than their worth, just make your own.

The “Separated” resources are specially easy to make, if you want i can show you how.

Thx but making a bar is not a problem, i’ve already solved with a tiled sprite

1 Like

Thank you for reporting this issue. It should be fixed with the 1.1.3 release of the extension.