[SOLVED] Bugs after updating to 5.3.200

I started to have issues with an object of my game after updating to 5.3.200. I had made a platform that disappears after some time when the player steps on it, and then reappears. It used to work perfectly well until the previous version. Now looks like the events that make the platform work simply don’t happen. I still can’t figure out which condition or action is ‘broken’. But downgrading to version 5.3.198 solved the problem. Something similar happened recently and the devs were able to fix the bug really fast. I hope this bug can be fixed quickly so I can update to the latest version again.

1 Like

Take a screenshot of your events and post them, that would be way more useful.

Basicly you said that theres an issue… but then gave nothing to show where the issue might be, how the heck are people gonna guess how your making the platform disappear, what events are you using and so on…

1 Like

It’s like none of the events involving this object happen, and the platform behaves just like a normal jump through platform. Thats the way it should work: the animation of the platform starts paused. When you step on it, the animation resumes (its a countdown clock). When the animation finishes, the platform is deleted and an explosion animation takes place. After a while, the platform reappears. After the update to 5 3 200, It doesn’t even activate the “countdown” process that makes it “explode”, disappear, and then reappear. I created this object about a year ago and never changed anything in the events since then, so I dont think there’s anything wrong with the way I made the events. Downgrading to the previous version of gdevelop made it work again.

Hope these information are useful. I’m sorry I didn’t post the screenshots earlier.

1 Like

What layout is that? its so strange seeing the Conditions and Actions all vertically… it was messing with my brain haha …did you edit the screenshot? If so… why? Thar dosent help…

…well, as far as i can tell… i dont even know how that used to work in the first place.

Think the bug might have been that for some reason something that shouldnt be working, was actually working…

You see, your “Deleting the ExploPlat” and then creating object on its position… which wont work.

Your telling the engine to create something at the position of something that no longer exists, Deleting the ExploPlat should be at the bottom, after creating everything.

As for why the animation dosent start… not really sure on that one, but try making a “Debug” button, add the condition, if " X Key is pressed" then do the action to change the animation. If that works, then the issue is with the character not registering hes on the platform, if it dosent work, the issue is something else… try it, then update us!

…but first of all, change the order of the “Delete Object”, that one is a mistake on your end. No idea why it was working before, it shouldnt have.

1 Like

Thanks for your reply. The screenshot was taken from the mobile version of GDevelop. For some reason the mobile layout is vertical. I dont work on the mobile version, I use my laptop. But I’m not near my computer now so I opened the project from the cloud with my cellphone.
Yeah, I should put the action to delete it in the end, not the start of the actions. Thanks for pointing that. But I swear it was working before, with the actions just like that. I wonder why too. But considering the animation doesnt even start when the player steps on the platform, maybe the problem is somewhere else, isnt it?

1 Like

Ahh, sorry bout that… im a bit jaded with people bending over backwards trying to hide their precious events, like its some sort of secret family secret while asking how to fix it at the same time… my bad :slight_smile: Never used the mobile app, so i had no idea.

I believe you when you say it was working. If there isnt a whole lot going on, the engine might read your events so fast that the order dosent really matter for a moment, but that dosent mean thats how it should work, always be aware of the order.

…and before you can tell where the issue is, you need to narrow it down by debugging what you want to do.

So… if i was you heres what id do…

On the event where the player steps on the platform and it tells the platform to change animations… add the “Play a sound” action at the top. Play any annoying sound, this is for debugging.

If the sound plays, then its registering that the player is on the platform and the issue is with the changing of the animation.

If it dosent play the sound, then the issue is the character not registering hes on the platform.

After that, we move to the next stage… but for that, we need to know which one of the issues is first…

1 Like

Well, I’m also having issues since the GDevelop update to 5.3.200. My player character is emitting grass particles on platforms with grass on it. However, when he’s on a crate, he shouldn’t emit any grass particles. Therefore I used the condition Player is on platform Crate to decide when not to emit any particles. Before the update all was fine, now it’s bugged. So I think the culprit is Check if a platformer character is on a given platform. The workaround Player is in collision with Crate solved my problem.

Screenshot 2024-04-24 152607

1 Like

I just tested this and i can confirm, the “Is on a given platform” dosent work.

The strange thing is, before i tried testing for collision against a “Platform” object and that didnt work, but now it does.

So im guessing something got swapped on there…

…but anyways, yeah, this is a legit Bug!

1 Like


True, I can also confirm that this worked fine yesterday, but after the update to 5.3.200 it stopped working.


1 Like

Yeah, I know what it looks like when people post without giving details, I’m sorry about that. That’s embarrassing. Haha :sweat_smile: I kinda forgot to post the screenshots in part because I was in a hurry, but also bc the last time I tried to report a bug the devs had already found it, so this time I just chilled out. I dont keep my game “code” in secret, it’s a pleasure for me to share how I’m developing my game. Hope the information here in this post is useful to find a solution.

Thank you for reporting this issue. It will be fixed in the next release.


Thank you! And, once again, sorry I didn’t post the screenshots earlier. :sweat_smile: I won’t forget to do it next time.

I’ve just updated to 5.3.201 and everything is back to normal. Problem solved! Thank you all for the support.:v: :smile: