[Solved] Camera tweens stopped working after update, changing durations to seconds didn't fix them

I just updated to 5.3.180 and now half my events are deprecated… The most troubling issues being anything involving camera tweens. My game has an active camera that zooms and rotates and moves constantly, at least it did before this update. Now it works on some layers but not others. The wall tiles are on a separate layer, and for whatever reason they rotate when they’re supposed to, also the layer I use for bullets and explosions seems to work properly. But the base layer and the layer below it do not. I went through and changed milliseconds to seconds which I assumed would fix the problem. It didn’t. Do camera tweens just not work currently or am I missing something? The game worked fine before the update. Before I try going back to a previous version I figured I’d post this.

Can you provide a eventsheet image of the camera tween? (The one that is not working)

Yeah, I mean I can, but I didn’t bother doing that in the first place because the events are literally just along the lines of: "player is not dead, gamepad button up pressed- tween camera rotation to 5 on layer Floor, linear, over one second as ‘cam1’ " with the action talking place three more times for the other three layers. It’s all worked perfectly until the update, and I don’t have any deprecated conditions or actions after the cleanup I did yesterday. But yeah, I’ll upload a screenshot as soon as I’m back home.

I had a similar problem using tween of a scene variable. Those events always worked fine, but with these latest versions I had to redo the actions to get them to work correctly. I think the problem is that the game is not being updated correctly to the new versions (it is not being rewritten with the new structure) or at least not completely.

1 Like

Yeah , that seems likely. The strange thing is that even though all of my tweens were deprecated, they all still worked before and after I redid them as far as I can tell. It’s just the camera tweens that stopped working on the base layer and the layer below it. Hopefully there’s a simple solution for this that I’m just not seeing.

When you changed the times to seconds did you also change the actual actions. The app seems to currently have 2 versions of each action. one in ms that’s hidden unless it’s already used and the new one in seconds.

I opened an older project with the tween in ms. Changing the number just changed it from 1000 ms to 1 ms. They couldn’t just do a swap or conversion because not everyone uses fixed numbers. There are times when you might use a variable or formula.

It gets confusing because you can have both versions.

1 Like

Yeah, I changed all the actions to seconds. They stopped being deprecated when I did (I have the “show deprecated behaviors” or whatever it is toggled on in preferences)

1 Like

I have tons of events with tweens…do I have to change each and every one of those actions? because that would take enormous time and effort.

Thanks. I wasn’t aware of that setting. Mine was off.

It’s a shame there isn’t a button or menu option to change the action to the new version with a click. It’s tough to find the new version. All of the tweens look alike. You might still have to change the value but if it did a swap with the old data, it would help.

It definitely helps to have it on.

1 Like

I think that the old way and the new way can coexist, it’s just that there are specific cases that seem to generate an error and have to be rewritten. The rest of my game seems to work correctly…and more than half of my events have the deprecated actions and conditions warning. I should practically remake the game. I don’t think it is mandatory to redo all the events, since this would greatly affect those who have been making a game since before the latest versions of Gdevelop.

1 Like

Oh, I meant they stopped being deprecated but they still don’t work.

The people behind Gdevelop need to be careful. There’s been a rash of bugs. IDK if they need more programmers or money or beta testers. Probably all of the above. It used to be very stable. I’m afraid they might be trying to grow too fast. With some aspects (like 3D) they’re way behind other apps. I’m not convinced that 2D and 3D can coexist in the same editor.


Agreed. I’ve had so many issues lately and wasted a ton of time trying to figure out where I messed up, only to find out the problem came from a slight change to a behavior or whatever. It used to be the opposite, I’d think I found a bug, but really I just had a wrong value or an action out of order etc.


So I created a quick project to see if I could replicate the bug, and I was able to. Here’s the events:

ezgif.com-video-to-gif (2)

Here’s a zip of the test project: camera tween bug

The issue is that 4 tweens have the same identifier so they replace each other.
I didn’t expect that the old tweens were allowing this, I’ll check tomorrow.


Yeah, they absolutely were working before, I’ll check that right now.

That was the problem. Thank you and everybody else that helped so much. It’s weird that it worked previously, but I guess now I know the correct way to do it.

1 Like

When some layers must move the same way, the Copy camera settings action can be added at the end of the events. This way only one camera tween is necessary.


1 Like

Awesome, thank you very much.