[Solved] Compiled Android-Apps crashing since GD 5.0.0 Beta-104

Hi guys,

since GDevelop 5 Beta-104 my apps are crashing rigth after the start. I tried the same app without any changes, but compiled with Beta 103 again and it works fine. I experienced this Problem with an older tablet running a Lineage Android 8.1. Webversion in the Browser on the same tablet works fine though…
Were there any changes in Beta-104 so that my tablet mith be too slow now? I also tried with Beta-105, but it didn’t get any better. Any ideas?

If you use admob please rewrite your key, and try a new export.
After that if the game still crashing send the apk for debugging here.

Or to moderators DM on this forum with a short description of what happend.

The game.json is also great for debugging if you wish send the file, DM or here.


I already rewrote the admob id and additonally removed the old id (duplicate from Version Beta-103 or earlier) via texteditor from projects .json file. I can send you the files, but I don’t think thats a bug within my project, because I already tried with two different projects. The only thing I haven’t tried yet, is removing the admob-id totally. I will try that later today.

Removing all admob-id references from the app fixes the problem… Strange… I will search for the issue and report on github later if I find it.


I know this is bad to reply to an old post but I have the same problem and I don’t understand !

Problem was the Admob ID. When copying and pasting it from the google admob page to Gdevelop it insertet a blanc space in front of the ID. That caused the crashes. Deleting the blanc space fixed it.

so this bug is fixed ?

From what I’m reading here, the bug wasnt a bug with GDevelop but an issue with how the users admob settings were configured in their project.

then there maybe is a bug with GDevelop.

Not according to this poster’s responses, no.

But if you are experiencing something else you are welcome to write up a bug report explaining the errors and an example.

That‘s correct, there was no bug. Just check whether your admob id is inserted properly without any blanc spaces before or after it.

1 Like