[Solved] External Layout doesn't get created

Hi, everyone. As I was developing my game, I ran into some trouble. I was using External Layouts in my game (well thinking to before I ran into this bug). So the problem is, see here:

The action I pointed out should create objects from an external layout but it doesn’t. To further more clarify it, see here:

And this is my External Layout:

Here, I am counting the number of WinOverlays in my scene and displaying them as text but see the gameplay:
We can clearly see that it shows “0”. Shouldn’t it be 1 if we create objects from the External Layout at the beginning of the scene. And this is all I have to declare this a bug.

Check the Layout name remember this is case sensitive, and please don’t call objects with the same name as layouts is a mess later

I checked the Layout name many times and as far as my eye goes, it is correct.

will it impact on code/game too?

Edit: I guess I really got blind :sweat_smile::sweat_smile::sweat_smile::sweat_smile::sweat_smile:
The damn thing is working again as I spotted the mistake.

No it’s just for you to get order in your game, if the game goes bigger it’s a good practice to camelCase the names of the objects and variables so as the layouts and scenes.

Show me your layers from the editor is there a layer

Edited: Ah! ok