[Solved] Gdevelop update broke my games?


I don’t know what you did with gdevelop(on the updates), but today I went on both my projects, made a mini UI update (no code change at all), exported, and got a huge error that made the app not load. I figured out after awhile that the “Advanced Bloom” effect is now broken outta nowhere. I use it in all my games. I removed it from all my games and scenes, then exported again. It loads, awesome , but now my ads don’t show anymore, they used to, but not anymore.

What happened???

After wisely looking and thinking, I’ve come to the conclusing that indeed Advance Bloom might have a bug, and that perhaps AdMob just doesn’t have any ads for me atm…

If you think I’m wrong please lemme know what you think, and also if I should open a bug report for Advanced Bloom.

Nope tyvm!

Just gonna add that there still aren’t any Ads showing. Gonna keep waiting to see.

1 Like

Starting to think it’s Gdevelop somehow cause ADS still aren’t showing and it doesn’t seem to be out of inventory. I’m very concerned :confused:

If you read the “what’s new”, you know some layer effects have been added/updated. :slight_smile:
It’s possible that you need to edit your effects (in layers menu and in your events) to update the instructions/values. Just open them and check that all the values make sense.
It’s possible there’s a bug too. :wink:

There is a bug on the advanced bloom effect in the current build, it’s fixed for the next update.
I recommend you to disable it until the next update.
If you encounter a bug with another effect ping me please :slight_smile:

1 Like

Hello, thanks, already done as stated above, only way I got my games to run.

Now, are ads broken? Cause they worked before and completely stopped showing now. And they don’t seem to be out of inventory, also, test mode also show nothing.

Didn’t change anything (code) since when they worked.

Some of my apps are being accepted and published to Google Play. Right at the last second ads stopped working.

I really need to fix it. Everything worked, gdevelop update, then not working. What can I do as fast as possible to fix this?


Thank you

Ads work fine to me.

HERE AN APK EXPORTED WITH B92. Ads working fine to me. Admob id are mine.

You can download the example project insert your id and test an export.
I’ve never upload a game on google play, so i can’t help much than the officiel documentation about the google play.

1 Like

Alright doesn’t work.

So your test app did show ads, but something broke in my game… I have always had a simple “Load & show banner” “at the beginning of the scene” (cant get simpler than that) which always worked but just like that stopped working without me touching anything.

My app ID and unit ID are fine, I know cause it used to work.

Edit: Like it always worked and should be working nothing’s wrong, I don’t understand

You shouldn’t load at the beginning of the scene, always load after an interaction. ie touch on screen.

1 Like

Hey, that’s only for the banner. My interstitial Ad doesn’t work also and it’s only loaded on “game over”.

EDIT: just changed it to try what you said but still nothing

Im starting to think it’s Admob somehow… test ads should at least work nah?

Edit: nvm actually idk, test ads should always show except if the implementation is wrong. So idk what to do anymore. It was working before… didn’t even touch anything… i contacted admob also in case…

Send me in PM your project folder with your admob keys setuped inside.
I’ll look into the game and try with my keys, if your keys have an issues your must continue to tchat with the admob team.

1 Like

Doneeeee! Tysmmmmmmmm

I got an email from admob saying they placed an ad serving limit on my account due to clicking on my own ads. (which I didn’t except maybe by accident when testing)

Could this be the issue you think? I don’t know what they mean by a limit, how many and how long for

Thanks, I was able to test and there seems to be a problem with your IDs.
I took your IDs, and used them in the test project, nothing works, the upload fails.
Same with your full set.

So the problem is with admob.

1 Like

Ohhh voilà!
That explains everything.
@Tic_Games Is there a way to see on the admob dashboard if this limit is active?
(I can mark this post solved ?)

1 Like

Consider the limit is 0, never do it. If you need to test, use the test mode, or ask someone else, or use a VPN.
Much easier to get blacklisted than getting unblocked. :blush:

1 Like

Are you saying other people can see the ads?