[Solved] I can't import font files

That “choose a new font file” button won’t show up. Not for a text object and not for a bbtext object.

version used: 5.0.122-beta1. But I didn’t check other versions.

Are you using the desktop version? Just checking because the web version doesn’t allow you to import files of any type.

I have downloaded and run the beta release and can add new fonts to all text object types that accepts TTF font files:
Normal text object:

BBText object:

(Bitmap Font doesn’t accept TTF files and only accepts .fnt/xml files and bmp atlasses)

1 Like

The desktop version.
I will try to reinstall it then.

Nope, I can’t.
Is it because I am running win7 64bits instead of win10?

I’ve tested on my old windows 7 tablet, it’s working fine.

Can you paste a screenshot of what shows up when you click into the font area?

(One more thing to check: make sure you’re clearing any text currently in the box, otherwise it is filtering the list of options below it)

I get nothing when I click on it, just like if I hadn’t clicked.2021-11-19,07-36-00-Selection

Can you try with a prior version of GDevelop? see if it opens there?

deleting GDevelop’s folder in \AppData\Roaming didn’t work.

I will try a prior version of GDevelop now.

It works perfectly in 5.0.121

Hmm… I can’t reproduce it even on a Win7 machine, so it could be specific to your setup.

If you go back to beta1, can you create a new text object, click into the font area, then open the console? (Ctrl+Shift+I). We’ll need the console log (You might need to expand it upwards to get the full thing in a screenshot), but after opening the console you’ll need to click into the font field again.

I can use fonts in 5.0.121, do you want a log from that version for comparison?

This bug isn’t present in 5.0.121.
This bug happens only in 5.0.122-beta1 and has been fixed for the next version!

Thank you for your bug report.


No, thank you guys! :+1: