[SOLVED] Latest APK file won't install on Android even after my previous versions did?

Hey, in the very recent past I’ve successfully installed APK prototypes of my game onto my mobile device to check performance and such but all of a sudden, my latest build of my game refuses to install on my Android phone? I’ve checked the resources in my project and there are no missing/broken files (to my knowledge)

I’ve been doing a little research in the forums and it seems something similar has happened in the past though I’m a little confused on how the self diagnose an issue like this?

As stated above, my previous builds of my game have successfully installed on my Android phone so I’m assuming that maybe one of the extensions is causing this issue? I’m going to continue to try and self diagnose the issue in the meantime

Thanks in advance!

(EDIT: Just to double check, I even exported my game to an exe file on my PC and it seems to be working fine. It’s just the APK file that isn’t installing right now)

To be clear, is the installation or the launching of the application after the installation failing?

The APK refuse to install full stop.

Did you put something weird in your game properties? Special characters, spaces in package name, non-semantic version…?

Not to my knowledge (I don’t quite know what you mean by non-semantic though sorry bear with me)

AdMob and Firebase fields are empty

Alright, I think I’ve fixed my issue:

I uninstalled the current game version on my phone and then installed the new version and it worked?

The strange thing about this is that with all the versions of my game so far, it automatically overwrites the app with the updated version. This is the first time this particular APK file refuses to overwrite the older version???

Thanks for helping me to troubleshoot :+1:

I uninstalled the current game version on my phone and then installed the new version and it worked on techysheky, its great.