[Solved] Layer Effects Failure

Hello, I am sorry if the text is not well understood, I am not good at English.

I am publishing this because I have exported a game, and the layer effects do not work in the exported game, but in the gdevelop editor they do work. Can anyone help me?

Which export ?
Which hardware?
Which layer effect?

The export is from windows to windows and html.
Hardware is a lenovo ideapad 330
And effects are: Sepia, Black and White, Blur, Dark Night, Pixelate, RGB split, CRT, Godray, and ASCII.
They should work when a variable is equal to a x number, for example: Variable “mod” = 1 the efect Sepia works. But in the exported game the variable is equal to the number and the effect not work.

Same problem here. When running directly from GDevelop, effects show ok. Exported to browser (Chrome version 79) and Android (Platform 28 SDK), effects don’t show at all.

Test of Sepia effect in an example project:

Running from GDevelop, effect shows fine, but when exported to HTML 5, there is no effects at all:

Link: https://unforgivenexception.com/sepia/index.html
Project (zip): https://unforgivenexception.com/sepia/sepia.zip

Solved for upcomming release.

1 Like

Awesome! Thanks for the quick reply Bouh, very much appreciated!

EDITED (in case someone has the same issue)
Check version v5.0.0-beta88 release:

1 Like