[Solved] Not condition doesn't work properly anymore

I restarted the app and my game was bugging. It appears the Not condition is not working properly anymore. As a condition with nothing is true by default Not(nothing) should be false. It was before but not anymore. Did something change?

There was a problem with the NOT. The only change I recall and could find in the history was:

Fix the Not condition to handle its last sub condition correctly

What events are you using?

Here’s a long discussion about the problem

just as I said. Here is an example. The result is printing NOT in the test text. It should not. Few days ago it was working. It started to bug after I restarted the app.

Does the NOT condition work otherwise? Why would you need to use invert without a condition? In any other language it might generate an error message.

To clarify something here:
There is no such thing as a “Never” condition in GDevelop.
The Not operator isn’t intended to work without conditions within it. If it did before, that was a bug.

Another illogical behavior then.
What’s also concerning is that the logic changes. So it introduces new errors

yes it does
to save stuff

If you are wanting events where you can have it not process in your code when previewing, just right click on the event and choose disable, or select the event and press the D key on your keyboard. Then you can have as many conditions or actions as you want “to save stuff” without it impacting your previews

That said, I have now checked as far as b110 and it didn’t work the way you are describing, so while I cannot say why you believe it worked differently, it definitely doesn’t appear to be a sudden change, and may have either been a bug in a singular version that was fixed in a following version, or something else in your events were causing it to behave differently.

1 Like

thanks! That’s very strange. I used it a lot so for sure NOT(nothing) was True.
Is it supposed to be False or give a random behavior? I ask because I have added a false condition to these blocks without erasing the NOT(nothing) and I had weird behaviors sometimes. I erased the NOT(nothing) and so far it seems okay…