[Solved] Only Shows Black Screen After Export

Hi! I’m new to this whole game development thing, but I’ve made a game, and I’m ready to export it now – the export seems successful, but once I get the game over to my phone and install it, when I open, it shows nothing but a black screen?

Any suggestions/ideas on things I can change to fix this? The package name is set, the logos are there, and there don’t seem to be any errors when exporting. The GDevelop preview works just fine, it just doesn’t work once exported.

My goal is to have it available as an Android app, as well as a Windows and Mac program. None of the three are working, all show up as a blank screen once installed.

Help!? Thanks!


Strange, but it seems it’s related to your game since it affects android/windows and mac.
Try to verify your ressources, and remove unused or missing references to ressources, and let us know if it’s still happening.

Resources are checked, still doesn’t work? There is an option for resources when I click to see their properties with a checkbox for “always loaded in memory,” should that be checked on every resource?

But otherwise, resources are good, all file paths are good, nothing unused/missing or anything.

No, these is no need to check “always loaded in memory” at this point.

Hum, if ressources are good, then something else is happening.

Can you preview your game over wifi (it will start a local webserver on your computer), and open the url generated in your web browser (chrome or firefox) ?
Does the browser make black screen too ? If yes, then open developper console (ctrl+shift+i) and look for errors.

Preview over Wifi works perfectly, opened the link in Chrome with no issues, everything works there.

In the developer console, the only errors say “Failed to load resource: net::ERR_INTERNET_DISCONNECTED,” although I did all the work on the project offline, so not sure what that is coming from? All resources are checked (and on my computer, not online?). Any thoughts on that?

Also, thanks x600 for helping, really hoping to get this to work!

Let’s troubleshoot some more. :muscle:
Have you tried turning it off and on again?:grin:
When you say you get a black screen, you don’t even see the loading screen with the GDevelop logo, right?
Can you confirm the steps you follow to export the game? Have you tried to export another project or an example project, to see if the issue is specific to one project only?

1 Like

For the message seems that can’t reach network are you trying to download something??

1 Like

Turning on and off didn’t help (although that would have been frustratingly perfect, haha).

And yes, there’s not even a loading screen with the GDevelop Logo or anything, just black.

To export the game, I’m doing the following:
File–>Export–>Android–>Package for Android–>Download.
(I have also tried to export to macOS, which also doesn’t work).

Other projects work, it’s just this one that isn’t working.

Now that we know your issue is related to your project, we’ll need more details about it.
Well, if you’re willing to share your project and if it’s not too big, it would be the easiest. Otherwise, maybe you can tell us a bit more about your project: how big it is, do you have ads in place, do you load data from JSON files… or anything that might be considered out of the ordinary, compared to the example projects.

The JSON file is 1.1MB, and it’s fine to share – although if I just sent the game file, won’t that mess with all the file directories for the resources, which are based on my computer? Does just sending the JSON file work?

There are no adds, nothing linked to other JSON files, no fancy functionality or anything? It’s basically an educational program, so you click things that link to other scenes, or you click things and an audio file plays. There are also a few scenes that are simple review games (question appears, click the right answer, next question).

If different resources are not in the folder with the.json file, export your games to local export and add the.json file with the export files.
You must make a.zip or.rar archive of your game folder.
You can host your files here: send.firefox.com

I took a look at your game. I confirm the black screen as a Windows executable.
Your HTML build works fine though.
The game itself is very basic indeed. But you do have some unusual characters (ስራህ ምንድን ነው) along with a custom font. Is there an incompatibility between that character set and your font or the compilation process, I don’t know. It’s my best guess for now, but I’m out of build slots, so I’ll test further later.

Okay, so I deleted everything except for the menus (so kept the custom font, deleted the foreign characters), and it worked. I’m out of builds for today, but I’ll see if the foreign characters are the problem tomorrow. I’m hoping that you’re right. It’ll take some work, but if replacing the typed characters with image versions makes the export functional, I can do that!

1 Like

The custom font isn’t the problem, nor are the foreign characters :confused:

do you have ads in your game?

This question has already been answered @xisco.

@dianamg, I don’t have much time to test at the moment, sorry. You said it worked at some point, what did you change that made it not work again? :thinking:

No stress, it’s my project, no need to spend your time on it! It never worked as a an Android export, at this point I’ve just started re-building the game as a new file, and testing the export with every scene. Oh well. So far so good on the new build, except that the sound effects aren’t playing.

I have the same problem when I export for web

this is my test game

I have the same prob as he do.
My game runs fine in preview mode, window export.
But when i install its apk file and opens it it only show a black screen without even gdevelop loading screen
Steps to export:
export>android(not manual)>gives .apk file which shows nothing on install and open
I also tried manual method for android but got the same black screen
on top of it i tried same thing with the example platform game given in gdevelop still got black screen in my mobile

and also working fine on web browser export option :’(