[SOLVED] Performance and preview problems since version 5.2.175

Hello! :slightly_smiling_face:

It’s been a few months since I’ve worked on my game. Today I’ve been messing around with a few things and I felt that Gdevelop was slow with the last version 5.2.176, but I thought it might be my PC that has very humble settings and I had some heavy stuff openned (Krita and Browser). But when I started using the preview, it seemed to me that something was wrong. In addition to taking a long time to load, it was crashing the song that was playing on youtube. My character has a few separate sprites that follow a main sprite and sometimes these sprites appeared misaligned, other times the platformer character behavior was bugging causing the character to bounce or pass through the platforms…

So, I tested my game with another versions of Gdevelop with the same stuff openned in the PC and all versions before 5.2.175 they were more fluid, the preview loaded faster and from the few tests I did no bugs found. But as soon as I used the version 5.2.175 the same problems with 5.2.176 appeared.

I took a look at this version on Github and noticed that there was a change that caught my attention:

  • Upgrade games 2D rendering engine (PixiJS) to version 7.3.0. This opens the path to multiple performance improvements (faster WebGL rendering, and then WebGPU rendering) as well as optimised resources loading in the future.

Well… It was just a suspicion. :eyes: Obviously I have no idea what really might be causing these problems.

Oh, and from what I’ve been following on the forum I’ve seen users reporting similar issues since the last versions were released, but I thought it was important to report my experience too.


1 Like

The problem is not only on your pc, my gdevelop is having some of these problems too, like objects disappearing and the black screen, also, my gdevelop project wouldn’t save


Because I’m having kind the same problem I don’t think I need to create a new topic, but I would like to update it.
The new version 5.3.179 the preview no more show-me problems with platform behavior or misaligned sprites, but keeps freezing my PC a bit and taking much longer than expected. And most of the time it doesn’t load all images (most 64x64) and pink blocks appear instead.

Apparently, it only happens with my game that I’ve already been developing and that comes from previous versions. I couldn’t reproduce the preview issues in the platform example (with platform example it loads fast and perfect).

My alternative is still to use version 5.2.172, but in my spare time I’ll start some testing by removing some things from my game to try to identify where the problem might be. If anyone is going through this and has any suspicions, it would help me if told me here! :wink:


Hey, I was experiencing a lot of performance problems with 5.3, to the point I was having to restart GDevelop after running every preview basically. It would get to the point where it would take minutes from hitting save for the “project properly saved” popup appearing. Off a hunch, I went to preferences and disabled “watch the project folder for file changes…” setting, and performance immediately went back to normal. Might be something to try to see if it works for you!

1 Like

Thanks for the tip, dijondude!

Unfortunately it didn’t work. Maybe the preview has gotten a little faster, but the bigger problem remains: most of the images don’t load. I still can’t figure out why only a few aren’t loaded since the version 5.2.175…

But again, thanks!!!

Sorry for the inconvenience, I’m glad you found the setting!
Could you give me more info about your device? Is it Linux/Windows/Mac?
Do you have any hidden files in your project folder maybe?

Hi there! I’m running it currently on Windows 10, w/ Ryzen 2600 CPU and an NVMe drive. I don’t have any hidden folders in there I’m aware of, however I do manage my project using Github Desktop, so that is possibly a factor. The performance impact seemed to happen whether I was running GDevelop as administrator or not, and it is an installation and not running portably. The save folder is under /UserName/Documents/Github/ProjectName, so not a folder needing extra permissions. I’m away from the computer currently, but hopefully that includes all info that may help!

Is the root of the git repository in the root folder of the GDevelop project?
Meaning, is there a .git folder in the folder /UserName/Documents/Github/ProjectName?

I discovered there was last night, and unhid the folder and all subfolders and files. I also updated to the latest version 5.3.180, and turned the setting back on to test. I noticed that it extended the time before everything froze up, but preview loading still increased exponentially each time it was ran, and after about an hour saving would take over a minute to show the properly saved pop up after hitting ctrl+s, or from hitting save in the menu.

Thanks for the details. Could you check my post above and see if you can answer my questions? It would help a lot.

Sorry, I worded my response a little poorly. Yes, the root of the git repository is in the root of the project folder, exactly as your file path example shows.
Edit to add, the .git folder is specifically the hidden folder I found, and unhid it and all files/folders inside of it.

Hello again!

I would like to put on record here that the problem has been resolved in this latest version 5.3.183. It’s loading the images and it’s very fast now!

I am very happy and grateful! Thank you!!!