[Solved] Polygon collusion mask doesn't seems to work

Although my sprite has a polygon collusion mask and that’s also convex.

but my car act like it has only the default hitbox.

My car has physics2.0 behavior

1 Like

@4ian please take a look on this. Is this a bug?

1 Like

It’s not a bug. Physics 2 behavior has its own collision masks and is not using these hitboxes. You should edit the polygon in the behavior properties :slight_smile: (I know that it’s not intuitive, but don’t have a better solution for now)

Confusing indeed, maybe add a warning?
Ideally in the default hitbox window when Physics is enabled for that object, “warning: the default collision masks don’t apply to the Physics behavior”, or easier to implement, a red line on top of the behaviour settings, “warning: this behavior uses its own collision mask”?

Yes that’s fair enough.

I’ve added this warning in the Physics 2 behavior editor:

Hopefully that will make clearer that the physics shape and collision masks are two different and distinct things.