[Solved] Preview stuck on loading screen on one scene

Hello there!

So I didn’t work on my game since 2nd of October. I opened GDevelop again yesterday (2 new versions of GDevelop, I think?) and I can’t preview the main menu scene.The progress bar stops at around 95% of the way, or is full, but doesn’t load. I could go into another scene directly, if I previewed that one. But at some point, editing minor thing made that one crash on preview too.

Debug shows this:

I tried to launch a previous version of the project, which I know worked, but the problem persists, so I know it isn’t the project. It has to be the newer version of GDevelop?

What can I do? I really want to continue working on my game.

I tried to install the older version of GDevelop, but it instantly updates it to the newest one on launch.

Thank you in advance.


Downgrading back to the version I had before makes it work again.

Is this a known bug that’s being worked on, or is it the project’s fault with the newer versions?

1 Like

For @Cesar
A. While I understand you are frustrated something isn’t working for you, Please don’t respond to threads with gripes about an unrelated item. It makes it harder for the original poster to get assistance.
B. The In app purchases extension is just that, an extension. It is not part of the engine nor is there any guaranteed support for it, just like all extensions. I hope someone eventually decides to take a look at it, but the original author has decided to no longer work on it. So you will either need to wait for other folks to take it up or work on it yourself to resolve.

For the original poster @Zakmulnarah , are you using tilemaps in your project?

Additionally, rather than the preview debugger, can you run a preview and pull up the browser console (ctrl+shift+i inside of the preview window, then click the console tab) and see if there are any errors there, then post a screenshot of that?

Yes, I do use tilesets for my platforms. If it is of any importance, the scene that doesn’t load does not include them though.
These are the console errors that pop up upon the infinite loading:

Thank you in advance @Silver-Streak !

1 Like

@Cesar all of that is fine, again I understand you are having an issue and have concerns. None of that is related to this thread, nor was your first reply above related to the loading issue mentioned , and my points about the iap extension not being a supported part of the engine remains. Please keep in mind my recommendation about keeping your concerns and issues out of unrelated threads, thank you.

@Zakmulnarah those errors mention numerous invalid or missing sprite image resources. Are those sprites still listed in your resources tab? If you remove them from the resources tab, does the preview work?

(Or does the error change, at least?)

I’ve tried it just now @Silver-Streak , but the issue remains. I removed the scene that brought the issue and the sprites from resources. The error looks like this:

Thank you for the continued help!

You might try the nightly release, they’re making some changes around the image manager.
First, backup your project (open it up, click the file menu, choose “Save as” and save it to a different folder entirely).

Then download and install this version (same version number, but has other changes in the engine from the Github) https://gdevelop-releases.s3.amazonaws.com/master/latest/GDevelop%205%20Setup%205.2.176.exe

Then open up your project in the new version and see if it works.


I just tested it and launched the preview a few times and it worked fine all those times.I didn’t know they had nightly releases! Thanks! I’ll stay on the old version and wait for a new release then!

1 Like

Preview works, but some things do not get loaded. Tileset is MayanPlatform and MayanPot is not a tileset. I tried to delete the objects and remake them and it persists.

Any new sprite or tileset I add shows up as:

Along with the erroes posted above. This is on the 5.2.176 nightly version.
I reverted to the 5.2.172 version, where both the preview and the sprites show up correctly for now.

1 Like

I am having the same issue and this his very useful to know! It is a bummer but i hope the next update addresses these issue

You are right, post deleted, not subject of original post.

Unfortunately I’m out of ideas, still seems like something odd with tilemaps in some way, but I’ve notified the dev team.

1 Like

It seems that your files don’t have any extension. Can you show what you have in the resource editor for “MayanPlatformMiddle2”?

Some things in my resources have .png at the end, some don’t. It all seemed to work fine in the previous version. (I don’t have MayanPlatformMiddle2 anymore, as I reverted to the old version 172, and I’m working on the game on it currently.)
Platforms are tilesets, the pot is an object.

I’m not sure if I am taking screenshots of the right things.

@Zakmulnarah I see your answer in @Silver-Streak’s message that the nightly build doesn’t crash.
It will be fixed in the next version then.

1 Like

That’s great news! Will the sprites that you import showing up as pink be fixed too?

I’m looking into it as we speak, I’ll try to have something that works.

Thank you for all your work and good luck!

I’d like to add I have the same issue while importing videos, the preview stucks on loading screen on all scenes when I upload any video to the project on the web version. I’ve also tried downloading the Video Player example video and uploading it to a project and it won’t load.

Those loading issues have been fixed (GIF, videos), as well as the pink textures for images with no extension in their filenames.

The upcoming release should fix all of those issues.

Thank you all for reporting the bugs and sorry for the inconvenience.

1 Like