[Solved] Preview Stuck on Loading Screen

So, it’s been a while since I’ve worked on my game, and I decided I would work on it today. I started programming a health bar, and I tried to preview it to see how it would work. But the preview would not load. It was always stuck about two-thirds into loading. I tried restarting GDevelop and it still always got stuck in the same place.
Edit: I tried working on other projects and they work fine…


If you have saved the changes you have made recently, can you delete what you have recently added (without saving after deleting them, because otherwise you will lose it) to see if the same thing is still happening to you? If it does not happen, it may be that the problem is within the event programming, which is generating an inconsistency and that is why it does not finish loading. Another thing you should do is enter the developer tools to see if any errors appear.

1 Like

Hi @Shark_Chum,
Thanks for taking the time to post this bug report.
I’m working on this and I would like to know if you could send me your project so that I can have a look?

Is there a way to send cloud projects to someone??

Can you go in File > Save as, select Download a copy and send it to me?

1 Like


So I found what’s wrong in your project: you use GIF files.
While is was tolerated in previous versions, new versions of GDevelop use a new version of Pixi (rendering engine) that silently fails when loading a GIF file in memory.
What I suggest is that you use online tools (Split GIF image in frames for instance) to split your gif into different frames and that you rebuild your object animations to match them.
On my side, I will add warnings here and there so that it’s easy to understand what is the issue.

Thanks for your help with debugging this!

1 Like

Last question: on which platform are you using GDevelop? Ipad? Safari on an apple device?

EDIT: I wonder how you could have added a gif in a Sprite since we don’t allow it.

Answer one: I originally used it on a Frunsi RubensTab (an android tablet), then, I switched
to a Windows 11.
Answer 2: For one of the objects, I tried to import a GIF so I wouldn’t have to upload multiple different images. The GIF just became a frozen image, though, so I just ended up using separate images.

  1. That’s weird, you should not have had the possibility to upload a GIF file in the first place.
    Do you remember using a hack for this?

  2. We were thinking about letting someone use a GIF and when they do, we split it in different images so your case is an argument in favor of this feature request.

1 Like
  1. I did not use a hack (I think…).
  2. Letting someone use a GIF and just splitting it into separate frames is a fantastic idea!