(SOLVED) What happened to copy and paste?

Copying and pasting events is not working, it appears for a second that I can paste the event that I just copied but when I click it, it just don’t work.
I tried ctrl+c and ctrl+v inside an event and it copies it but when I try it on another event it doesn’t.
Something went wrong with the copy and paste in beta 103, I’ll get back to 102 until it’s fixed, really hope this gets addressed soon.

maybe some sort of installation error.
I can copy just fine. Even between different gd instances & scenes.

1 Like

Weird, I’ll try re-installing now and let you know what happened.

@Slash Nope … same problem after reinstalling.

What size are we talking about?
Like 50 mb worth of events?
Does the error occur on 1 single simple line?
Could be a memory issue

1 Like

@Slash Hmm… I don’t think it’s a memory issue at all as all previous betas work just fine with me (since like beta 30). this one feels like a bug. I can’t copy and paste any line, but everything else is working just fine, Gdevelop is installed on an ssd with 8 gb of ram, I never had this issue before with gdevelop, so weird.
I’m downloading beta 102 and will give it a try and see …

really weird.
i just tryed with like 50mb event size. copy paste still works for me. strl +C / right click, both work.

are you using the windows version? Do you use any of the new event functions?

1 Like

Ok so this kinda weird, I think the problem is with me not gdevelop, I tried beta 102, 98 and the problem still exists whether it’s my project or a blank project.
I even got into appdata to remove any thing from gdevelop and do a clean install and still the problem is there.
I don’t know what is wrong really, this never happened before, I really can’t work like that.

You use a touchscreen or a mouse or a pen/stylet?
If a recent version works for you which is?

On desktop you can see the content of your clipboard, do a copy of an event and in a plain text software do the paste shortcut.

You should seen something starting by :

{“000kind”:“GDEVELOP_EventsAndInstructions_CLIPBOARD_KIND-jsBdHbLy912y8Rc”,“content”:{ …

If the clipboard didn’t containt this kind of text, tell us.

If you can see that but not paste the event in GD with a shortcut maybe a button works for you?

@Bouh Alright so here is the event I copied

and here is when I paste it as text (in Notepad):

Could you explain more, I don’t understand this part…

@Bouh This is weird, whenever I try copying this part and then paste it:

I get this:

what is that?

@Bouh do you know how can I fix this?

This is just different type of content (event or action or condition) in your clipboard.

You have the paste button with right click. And for action/condition you have these buttons:

Btw you can change the shortcut of copy/paste in the preferences of GDevelop !

1 Like

So I managed to fix it by re-installing my windows … Not the best fix yes but it works now.
Now I think I know why the copy and paste wasn’t working and I’ll explain down below:
A couple of days ago I found this tool called “Windows 10 debloater” … basically what it does > it deletes all of the unnecessary programs that comes with windows 10 (games and useless programs and stuff like that) making windows 10 boot significantly faster (in less than 6 seconds in my case and sometimes even 4 seconds which is crazy) and the overall performance of windows much better.
Everything was working just fine but apparently this tool gets into the registry and other deep places that it did something with the copy and paste …
I found today that not only gdevelop had problems with copy and paste but it happened inside my windows when I try to copy folders or files and other stuff (sometimes it happens and sometimes it doesn’t).
So would I recommend “Windows 10 debloater” ?
Yes I would but only if you’re not a game developer or you don’t work with heavy programs like photoshop, illustrator, gdevelop and stuff like that, it’s best if you’re a gamer (it can help a lot with cpu usage and ram usage) if your pc is struggling a bit, kinda sad that I won’t be able to use it now but it’s alright, I got a new SSD so I think everything will be alright.
If anyone is curios about “Windows 10 debloater” … it’s 100% safe and I used it for many months, here is the link on github: GitHub - Sycnex/Windows10Debloater: Script to remove Windows 10 bloatware.
Anyway problem solved…
Thanks a lot for helping : )


You might want to open an issue to let them know about the issue you had so they can try and prevent this from happening to other people :eyes:

1 Like

@arthuro555 well it’s about a tool “Windows 10 debloater” not gdevelop related so yeah … no need for that I believe, at first I thought it was gdevelop related but it wasn’t. Gdevelop is working just fine as it is.

Yes I meant put up an issue on the Windows 10 debloater github