[Solved] Wrong alarm...raycast is working in latest ver..sorry forbothering

I have a moving object with a laser pointed on, and a condition who check the collision.,
everything was working fine before the update, but now the laser often lose its collision so sometimes the condition is not working. Worked flawlessly before the update.

asking to check if everything is fine in 5.2.174


Would you be able to recreate the issue on a small project and share it here?
This would help understanding what the issue could be.


i cant post full conditions since too big, but basically ive this

and a condition who check the coollision.
if true the enemy follow; anim=walk
if laser not in collision the enemy stop. anim=idle

Worked good with previous ver but after the update sometimes the enemy stop while following as if collision is not happening.I mean he keeps to follow but he stops during the following since i see the idle anim for a step moment

I didn’t see this happen in previous ver…but it doesnt mean that it weren’t happening or was noticable

Edit: i solved deleting the laser when not in collision…but still…

Thanks, that’s helpful.

Can you tell me how you’re moving the geometry? Using simple forces? Using the physics engine? another behavior?

A screenshot would help again.


when laser is in collision it triggers the AI to 0 ; enemy chase player by force.

at the end i’ve that if laser is not colliding exits from ai=0 state. dont mind the trigger once i was doing some tests.

basically sometimes the enemy while chasing change to idle anime for a millisecond even if the laser hit the player…(or at least it looks so)

ofc player is in the obstacles grp

i thought to remove the “bridge” i made between the laser collision and the chase state by ai var but honestly i need that conditions…

also if it can help, if u look above i set up the laser to be 1500px it means that the collison should stop if player is fartest than 1500px, but the enemy block sometimes even before.

EDIT: Thx . for your support i fixeed the problem using a static sprite…it seems laser is working fine…sorry for bothering…:stuck_out_tongue:

pls delete

Happy to hear you’ve solved it :wink: