Some instances of Objects not showing in editor


I have been finding that some of the instances of objects are not showing in the editor window. They all appear in the game when running, but not in the editor. About half of the instances of a certain block is showing, and the other are not. They are all set to the same Z value. It was when I restarted the program they no longer appear. Does anyone have any ideas?

1 Like

When you say instances of a certain block, you mean instances created during the game through an event block? If so, it’s normal they don’t show up in the editor because they are not created yet.
Aside from that, you can open the layers tab and check that the layer of these objects is visible, and you can open the instances tab and see if they are listed.

Sorry. I should have said “object” or “sprite” not “block”. I have dragged an object into the editor screen and layed it out on the grid, but they appear to have disappeared in the editor view. So, they are unselectable.

It appears to be some kind of bug, though. Because I just discovered by accident, that if I drag an object and Ctrl-Z it to undo the action, the objects reappear.

Thanks for your help with the “instances tab”. I haven’t been using that nearly enough.

like gruk said, maybe your layer is hidden, and these object are on it.

I heard about issues from people with massive amounts of objects having that kind of problems :eyes:

1 Like

Does closing and reopening the project or GDevelop fix it?
Are you able to reproduce the issue in the example projects?

No. Closing and reopening the project does not fix it. The only way I’ve found so far is to move an object and then Ctrl-Z to undo the move. The objects then reappear. Its strange.

Thanks. I don’t have a large number of objects. They are tiled objects though.

Thanks for the suggestion, but the layer is not hidden. Everything is on the same layer.

Same disappearing act in a scene. The instances are there, they work correctly in preview mode… If I open Edit withPiskel, on the animation, then they reappear in the editor. Context, a sprite with static physics, to make a slope (using instances of the same at different angles)… Save and re-open - gone again… NOTE Some tests seem to point with resizing of the objects (only resized instances are not visibles) as the problem (placementg and rotation does not seem to affect visibility)

1 Like

I start to experementing this bug too.
This come to me when i use GD on during hours. Like if the memory has been used by something else and the image loaded in preview gone. When i restart GD my sprites come back.

This is still an issue in April 2020 (I am on Mac OS, don’t know if also in Windows or Linux). But as jmdeschamps suggested in his comment it’s connected to resized or not resized sprites in the editor.

:tada: Workaround: Open your project.json in a texteditor and set “customSize”: false; for those you want to have visible in the editor again. Then do the resizing in the code (e.g. at beginning of scene).

Or open the instance list in the toolbar of GDevelop, click on the instances, and disable custom size checkbox in the propertie panel.

Zooming in and zooming out with mouse scroll fix this issue for me

Edit: but it still annoying

I think I’ve had a similar problem. when I encounter it happens due to z levels. using multiple layers helps, so your object sprite doesn’t get stuck “behind” your background sprite

My tip for this issue is move any objet in any layer then Ctrl+Z in Windows 10, CMD+Z on Mac