Specific sound will not play no matter what

This stubborn sound will just not play no matter what I do:

I think it’s a bug that occurs when the sound is short, but here is what I tried:

  • I tried reuploading the sound countless times
  • I tested the sound file inside of the project (It works there)
  • I checked to make sure my volume is high enough (Other sounds work just fine)
  • I checked the option to preload the sound
  • I double checked that the event was only playing once
  • I checked to make sure the action was actually running (other actions work with it)

No matter what, this sound just will not play.

1 Like

Can you confirm the event gets called, say by changing the colour of the background? If it does change, could you share the wave file? Then we can see if your issue can be replicated.

I already confirmed that the event gets called. I can’t share .wav files on this forum. I think it has to do with small sounds.

You can pop it on a file share (Google drive works well), and share the link. What size is the file?

It’s 11.9 KB with a length of under 1 second. Maybe the glitch occurs because the system reads that the sound is 0 seconds and thinks that there is no sound so it doesn’t play?

It works fine for me. My sound file is 7kb in size, and 0.35 seconds in length :


Here are my events :

And it plays on every button click.

How are you confirming your event fires? Can you create a little test scene with the two events in it just like mine, and confirm that works?

It could be a preload issue, too. Without preloading I believe the sound has to load every time and can cause issues. Make sure it’s set to preload in your resources window.

I do have the sound set to preload, but no luck.

I can also confirm that the event is being fired because other stuff happens along with it. I even tied it to an “at the beginning of scene” event

I also uploaded another sound and tied it to the same event. That one plays just fine.

UPDATE: So I was correct, the problem was that the sound was too short. I opened a sound editor and added some silence to the end of the sound to increase the length of it, then reuploaded it and it worked!

But that is a bug and hopefully it can be fixed.

Just how short is it?

I’ve just tested it with a .eav that’s 0.05 seconds in length. It’s still audible.

I can confirm that any short sound I play, from 0.01 seconds to 0.9 seconds, wav/ogg/mp3, all work fine.

My best guess would be your original .wav was maybe in an unsupported bitrate (32 bit pcm isn’t supported by many browsers and android devices, although it should work in preview, I believe?)

I got a same trouble as this one. I convert my origin wav file from X bits(i dont know how much it is) to 16bits and it works well :joy:

problem fixed, maybe?