"Speed" should be called Velocity

  1. velocity can have a negative value, speed can’t.
    Speed versus Velocity


    For example, if I set a var to PlayerHitBox.PlatformerObject::CurrentSpeed()


    and go left, the var will get a negative value. That’s how velocity works, not speed.

  2. Most other engines, like GameMaker Studio, use the term “velocity” instead of “Speed”. That can cause confusion. (it caused me confusion, long ago)

I think that it would make more sense to use the word velocity.
I don’t really mind the word “Speed” instead of “velocity”, I just wanted to talk about it.

1 Like