Text Object Boundry Box not matching Font in Editor?

I ran into a new issue today regarding Text Objects.

After numerous adjustments, all of a sudden the editor started showing boundry boxes MUCH larger than the text objects themselves, making them appear heavily misaligned in the editor, although they still render right in preview.

For example, here’s what I see in the editor:

Here’s what I see in preview:

You can see the highlighted boundry box in the first image is MUCH larger than the font. I’ve confirmed the font itself doesn’t have any space above it (at least not anything close to what you see in the first screenshot). You can see the font here: Silver, a font for games by Poppy Works

I even did a test. This sprite object and this text are roughly the same size. However, to have the sprite object overlap with the font in the editor, I have to move the sprite’s Y further down by 10 pixels.


I tried reinstalling Gdevelop, creating a new scene ,etc. No matter what I can’t seem to get the boundry boxes to properly align with the font size, and cannot get the fonts to accurately represent their real x/y position due to this.

What I DID see, is that for some reason upon loading the scene, I will occasionally see a momentary glimpse of all the text objects loading with the default font. They then snap back to the selected font. What I believe is happening is the Editor is rendering the font at the bottom of the boundry box, but not adjusting the boundry box size from the default font.

This test seems to prove that out. You can see the boundry box of both of these (one with default font at size 37, one with the Silver font) are identical:

Again, I’m not sure what caused this, as it was working perfectly for hours. It also seems to be size specific. If I shrink the font down to 35, it works fine. As soon as I hit 36, the boundry box goes crazy.

Is it something with how this font is getting rendered? Any input is appreciated, as it is near impossible to align stuff properly in the editor now.

Also, this does not impact the BBText boxes, which is surprising.


What’s weirder, is the character size seems to be somehow based off some kind of GDevelop editor memory only?

  1. If I duplicate the scene (For testing).
  2. Save the project.
  3. Exit GDevelop.
  4. Edit the json file for the scene in Notepad++.
  5. Replace all instances of “fontSize”: “37” with “fontSize”: “35”.
  6. Load back into the project, then load the test scene up shows size 35 now has the issue size 37 had before. As does size 36. Size 37 now works fine. Changing back to 35 breaks it again.

No idea as I can’t find any project settings related to the font at all, and I’m unclear where GD5 saves its settings to check there.