Text object not using custom font

Hello, I have a text object and I want to use a custom font I downloaded but after selecting the .ttf font file and applying the change the text in the scene doesn’t change. Tried creating a new text object with the font file, didn’t work. Next I created the text object, applied the change, then opened it to edit it and added the font file, applied the change, and didn’t work.

I’m either missing something or it’s a bug. Thanks for the help.

Is the ttf font added to your project resources?
Try copy the font you want to use inside your assets folder then add the TTF to the Text object and try again.
For instance in my project I have the TTF inside Assets/fonts/my-font.ttf

I tried it and still didn’t work. The other way is that the font file was downloaded in a .rar file and then I extracted the .ttf file into my projects folder, didn’t work. I tried creating an assets folder with a fonts folder inside and then put the tff file into that like what you have, still didn’t work. When I load the tff file when it’s already in my projects foldier it doesn’t give me the message asking if I want to copy, but when the file is outside of my projects folder it gives me the message and I click yes and even when I say yes it still doesn’t work.

But it shouldn’t really matter if the tff file is inside the project folder or not, the fact is that the upload your font is bugged.

This is weird if you can make a video or a GIF and report maybe is a bug, if you do that maybe a moderator can see the issue and helps you.

1 Like

The issue is not very clear, please make a video or give precise steps to reproduce the issue.
Make sure to check the Resources tab to confirm that the font is properly loaded.

I am currently using 5 different fonts in my game, so custom fonts works fine. I’ve even retested with new fonts.

There’s a good chance your font doesn’t adhere to TTF standards, is being blocked from loading by something in your resources panel, or other issues.

Here is a free for reuse font that I have used in the past and know it is good: monogram by datagoblin

Download it, extract it, and add it to your game. Do not copy it to your folder manually, select it using the “choose a new font file” in the drop down and say yes to copy it when prompted.

1 Like

Thanks for the reply. I’ve downloaded it from two different sites and neither worked. I’ve also installed the font itself so it seems to be legit, at least according to windows. Also when I right click and select properties the file type shows as .ttf and “true type font type”. So it seems like a legit file in terms of being a front file. I should try downloading other fonts and test it.

So I tested out that monogram font, and it worked. I also tried a different font from the same website that I downloaded and it worked which means the use a custom font works, but it is still bugged or doesn’t work with all custom fonts.

As for the steps taken:

  1. I went to the website that had the custom font I wanted and then downloaded the .ttf file to my desktop. If it was zipped I unzipped it to the desktop.
  2. In gdevelop, normally added a text object. In the edit window I made some changes like the font size, text, and color.
  3. Then I go and select the custom font, opens the “choose a font file window” where I navigate to the desktop where it’s saved, select it, and then press open.
  4. Click apply in the text object editor.
  5. Drag the text object into the scene.

Unfortunately, based off what you are seeing with it working with even one other font, then it is exceedingly unlikely (but not impossible) it is a bug with the engine

It is much more likely that the font doesn’t adhere to ttf standards and therefore is incompatible.

However, if you post a link to the font, one of the contributors might be able to take a look at it more closely.

This is the font I’m trying to use. Ok well, I’ll make the text in gimp then which the font works perfectly in.

Which version of all availables are you using?
Edit: I think is because this font is converted from this other one
Converted from C:\ALLTYPE\ARMY1602.TF1
Which is not a ttf
And I can confirm that this font doesn’t work at all in any of the versions

Optionally you can use Hiero o BMFont to convert that font into a bitmap font and yes it works.

Here the converted by me font:

1 Like

I don’t know what you mean by all availables but I’m using Gdevelop 5 and a ttf file that windows says was converted from tf1. Also, I tried bmfont and when I went to select the fnt font file I can only select ttf files and that’s it.