The clicker project

Hello !
Today I present a small project that was close to my heart that we can say is 50% finished: The clicker project. The goal was to create a style games coockie clicker but can be modified [u] EASY [/ u].
So I’m reaching for something playable I post so the games here you can find the page here gamejolt:
(the download is on the page)

The default skin is adapted to League Of Legends (: roll:) but you can change the textures in “config / textures /” sound in “config / audio” text in “config / save / lang.ini” this is the text displayed next to the objects and improvements; and “config / save / messages / 100.ini” This is the text displayed as the progress in the games.

I expected beautiful skin on your part: P

From my side I continue to add content to reach a full playable game.

Update !
Now the game is available on Linux! 3 new objects are added. I fixed some bug and do some optimisations. A french pack is still available :!WJUWAZhY!j6woyNLP4 … S41WTQqx1g

If you have an idea / found a bug or make a pack share it :slight_smile:

Do you actually make enough money to from the ads to be able to withdraw it?

Am, after the “Made by Loustak” splash screen I get this:

As you can see in the terminal, for some reason it failed to load some images. :confused:

The game load images for the game (it make it “moddable”), maybe the game didn’t have access to this files :confused:
Try to run it in root ?
I’m not an expert for linux but on y unbutu it works fine…

I have changed permission for the game folder and all enclosed files so anybody can do anything with it, also tried to run it as root to make sure no permission problems, but nothing helps. I have compiled the platformer example it runs fine on my Ubuntu, could you please try it if it runs on your Ubuntu to make sure it not a bug in compile or with alternative path’s or something? (1.68 MB)

I don’t know much about it but maybe even after compile the Linux executable is loading files, images from the project folder instead of the exported game folder, and so it works on your machine but not on other machines on Linux.
If you get the problem with the compiled platformer example on your machine, maybe this is the case with Linux executable :wink:

I will try this but currently my portable pc dead :frowning: They will repair it but t can be slower…

Just something : The folder nammed ‘config’ is in the same folder of the game ? It contains images in ‘config/texture/’ ?

Actually there is no folders or images inside the game folder, don’t even inside the archive :confused:

I guess they are stored inside the executable or inside one of those files but I have downloaded the Windows version and copy the folder and images frorm there in to the Linux game folder and it works now :slight_smile:

As on Linux I never see images and folders in compiled game folder, maybe it is a bug on Linux.
Maybe the compiler forget about the images and folders when it compile the game OR they are stored inside the executable or inside a file but actually the executable load the files/images from the project folder, from same path (config/texture) but not from it actual location inside the game folder.

Maybe the GD platfromer I have uploaded not the best to test if it a bug, as the actual project folder and images (the example) can be found on every GD user’s PC, so I made a little project. When it run a few ship and green square sprites must be in the middle of the blue screen. Would be great if someone could test it and see if it works on a different Linux PC. On my portable PC running 32bit Ubuntu, so probably the game won’t run on that one anyway :imp: (1.57 MB)

Ok i missed to add the config folder to the archives that sut the game wont start.
So is not a bug.
The reason of why the game need to load images from a folder is to able the user to modify the game. So you can found game made with GD who dont need images contains in a folder :slight_smile:

You should be not required to add flles, folders and images manually after compile, when GD compile the game, GD should copy everything itself in to the game folder, also it seems like the game is running on the system of the developer even without folders and images inside the actual game folder but it not on other systems. So I’m pretty sure it a bug.

Regarding the game, Pretty good idea, I liked the mushroom to boost employees :smiling_imp:
imo, it would be more interesting if there would be some goals to achieve and limits.
Like generate X amount of cookies in X amount of time using X amount of clicks or using X amount of koreans and upgrades. Maybe you would have some limited number of points that you can spend on upgrades. Also the available upgrades imo should be unlockable as "reward " by achieving such targets. I have just reached 540 cookies /s in few minutes, and by now I have 300k+ cookies for everybody in the galaxy. So a goal, targets, and some limits, upgrades as rewards would make it definitely more interesting.

No, you didn’t understood. The images from his game are loader dynamically, so GD doesn’t know the images to copy, that’s not a bug.

Oooh I see, but what do you mean by that GD doesn’t know the images?
In the terminal, the executable is looking for specified images at specified location

I think this is the location “path” of the images in his project folder, so, if the executable looking for them in that location, why GD doesn’t know them :astonished:
What does it mean actually :confused:

Loustak uses actions load them at runtime, they are not in the image bank. :wink:

Exactly. For archivement is a very good idea i will try to add it :slight_smile:

What are those actions? I didn’t know such thing is possible in GD and if it is, it’d be very cool as I could add more capabilities to my game regarding modding.

Enable “drawing extension” for native plateform they are action for load images in image bank.