Thumbnail set not working

I uploaded the icons in the icon area but it won’t load the thumbnail set.

Perhaps you forgot to press the apply button?

Did you republish the game? That applies the new thumbnail.

yes, I hit apply and rebulish

1 Like

And it didn’t work???

The thumbnail file have to be named thumbnail.png or jpg I guess.
But is there is something weird we’ll look into it, we got your email, and see this bug report, thank you for pointing this.

1 Like

i was hoping this would be fixed in the new update… but it’s not. I even bought a sub to try to get faster tech support… can you help??? no one is going to use my game with no icon.

Can you screenshoot the thumbnail in the resource tab please?

Because it always worked well for my games.

Could you also share here a link to the game on
There must be a problem with the file I guess.

Here, it is


And the resource tab?

And the link?

Did you tried to rename the file 1 to thumbnail ?

Yes, nothing changed.

Hello, can you help me out?

I can’t help more if you can’t afford the required elements we’re asking for.

I sent you everything you asked for… what more do you want… I sent the thumbnail file, the assets ,the link, can you please help …why doesn’t it work!

Hello, is there anyway you can help me with my thumbnail issue.

Have you supplied the following?

They never, and that should have been the case days and days ago, but instead they are still asking for help without taking into account that there are people already trying to help them.
So I deduce that help is no longer needed.

Thanks to not asking for help in my private message again.