Version number doesn't seem to work :/

Hello guys!

I have a problem with version number.

So, I’m trying to upload second version of my game to Google Play Store for testing and I got a message that my .apk file is in 1.0.0 version and I’ve already uploaded one that is v.1.0.0. I’ve stumbled on this problem about a week ago but back then I could just delete one file from my Google Play Console and upload another file with the same version. Now, I’m really close to release and I am afraid it would look really weird in Google Play Store if I had a game that is “recently updated” and the version of the game would be 1.0.0 (I don’t know if that little “trick” with swapping the .apks by deleting one and uploading another will work with release version :frowning: ).

I tried to change the version number in the project “Properties” menu under the “Version number (X. Y. Z)” and it didn’t work. I tried to change it to versions 1.0.1, 1.0.8, 1.1.1 (in case 1.0.1 was somehow bugged) but it didn’t work as well. I tried to change version and export other projects like “Platformer Tutorial” and the file that shows you how to use AdMob and every time the version was 1.0.0.

I’ve checked version on my phone and android studio (in the AndroidManifest.xml file) and, in both cases, the version was 1.0.0.

Do you know about this bug? Maybe there is a quick solution to this problem?

Reported here:

So indeed version number was not properly applied. This is fixed for the next version that I’ll release probably earlier next week (monday/tuesday)