Windows text size zooms the whole gdevelop

When I increase the text size in Windows10 e.g. to 110%, the icons, game preview, etc. in GD are also larger and blurred. The Windows scaling is at 100% and 1080p.
I think this is not good behavior.
Can we ignore the Windows text setting for gdevelop?
“Override high DPI scaling by application” does not work.

I found a setting to increase the size of “text, apps and other elements” (bottom of my screenshot) but not a setting specific to text. Where do you find it? Is your Windows up-to-date?

It is in System > Display
but only if you search for “Make text bigger”

Indeed, I found a text-specific setting and it zooms the icons and the whole preview, which I don’t think it should.
But if you look at Chrome, it’s zoomed too (home icon, for instance). :confused:
I’ll move this topic to bug reports anyway.
@4ian Any idea if this problem comes from GDevelop itself or one of the components it uses?