Wobbling/Jittering Pixels when camera scrolls Bug


I think this is a bug.

For example when you use camera follow player

then occurs wobbling/jittering pixels on objects, or sometimes on background.

At first I was not sure, is the problem only in my game.

So i have tested two different games made by GDevelop:


when you start playing, already at the beginning of the game brown stones going towards you, occasionally for a split second are shaking.

very similar situation is with the game A pixel Adventure Legion

when you start playing, in first scene you can see how the trees are shaking.

after you continue to play, later in a dark scene the same problem can occasionally be seen.

So I hope this wobbling/jittering pixels bug can be fixed ?

Thank you

Lil BUB’s HELLO EARTH is maybe one of the first game made with GDevelop 5 beta, now GDevelop is stable and have the version number 5.0.135, we’ve done lot of change since the beta version.

A pixel Adventure Legion is a bit more recent, but this game don’t use the latest improvement made this year on the resolution and camera improvements.

You can try recent games on liluo.io, tell us if you see again this kind of jittering.


for example my simple game have wobbling/jittering on Android smartphone, while at the same time
it works normally on computer. And I am using latest version of GDevelop 5.

when I asked here on forum why this is happening, no one knows why. how is that possible ?

Also recent games on liluo.io, I would love to try on Android smartphone.
because the problem occurs only on the smartphone, not on the computer.

And out of curiosity, I tried the latest Platformer example game on smartphone.
when you move the player from left to the right several times, the clouds shakes…

therefore I think this problem is still here.

Thank you

A lot of what is being described here just seems like scaling artifacts from using a non integer resolution screen vs the game resolution.

I have a galaxy s21 and have no jitter on the new platformer example nor hello bub.

My super rough guess would be the mobile device being tested on is not an integer scale from whatever resolution the game being tested is. The platformer example is 960x540, and therefore scales evenly into my phone’s height when landscape (1080). If the device being tested on does not have a resolution that is either a (whole number) multiple of 960 or 540 on one of the sides, it isn’t integer scaled.

So what is being seen may appear to be “jitter” but is either subpixel rendering, rounding adjusting for floating positions, or both.

Just a guestimate, especially since I can’t reproduce the reported issue.

I have tested on Galaxy A52, and on Realme 6. on both phones i have the same problem.

is it possible to send my game (1mb), and then you export it for Android. and try it ?


Both of those should be fine for the platformer example if in portrait mode. If you’re seeing jittering there (when in portrait mode) you’re going to have to find some way to show an example of what you mean since I can’t reproduce it.

I do not currently have time to download other projects to review, but if you cannot find a way to show a representation of what you mean, potentially another user or contributor can take a look.

here you can see:

when the player moves right or left near green house

green house shakes or something strange is happening


i’ve really tried a lot, but nothing helps. i tried a few different cameras. I researched the forum but found no solution.

please can you help me, and check the files of the game ?

I have also open a topic, but with no solution


That just looks like either: Your game resolution is very small and positions are snapping to the next closest “whole” number with rounding, or it’s momentarily subpixel rendering so it looks like it’s juddering as it goes back to full pixels.

If that IS the issue, your only real solutions are:

  • Make your game at a higher resolution, multiply your asset sizes by that new resolution factor. This gives the screen more “room” to move in without hitting subpixels/jumping to the next rounded pixel.
    e.g. If your current resolution is 320x180, set your resolution to 640x360 (2x size) and multiply all of your assets by that same factor (2x).

  • You can also try my native resolution multiplication method: Jerky Camera + Lerp + Low Resolution - #7 by Silver-Streak

As a quick test, I did try this using the Tilemap platformer example:

Resolution set to 160x90 in the game properties.
Game resolution set to 1280x720 via events (window not resized)
Zoom set to 8x (8x90=720)
Framerate minimum set to 60 fps, max 120fps
Camera lerped to player location

Overall it seems pretty smooth to me, and these are the only events needed to accomplish it:

Instead of 8x/720p/etc, you would use whatever is a multiplier of your game resolution. For the devices you mentioned, I’d probably go up to 1080p as the resolution in the “Set game resolution” event. If your game resolution is 320x180, that means you need to change your camera zoom by 6x. (6x180=1080).
Note: you will need to zoom the camera for EVERY LAYER you have. And if you have any events that zoom in/out the camera, you’ll need to keep the multiplier in mind as well. (e.g, if you previously zoomed in 2x, you’re now going to have to zoom in 12x (2x6).


I will try native resolution multiplication method. to see if works for me.

and at this moment resolution of the game is 640x360.

if will not work, please can you spare some time to check my game ?

thank you


I tried native resolution multiplication method.
but unfortunately the problem is still the same
My game resolutioin is 640x360.
and i have used 1280x720 via events
zoom seto to 2x


Thats not going to work because now you have made it non integer. 720p doesn’t go into your display evenly.

You should try 3x and 1080p.

1 Like

ok. i tried 1080p, but still the problem is there :frowning:

is it possible to check the files ?

thank you