Won't change scenes

Hello, I am having trouble changing the scene from my credits scene. I don’t have this problem anywhere else in the game. As you can see from the screenshot, there is not much to it. When I click Back it simply closes down. Am I doing something wrong here?

What happens if you take the sound action out of the event?

Is there a button on the Character scene that’s in a similar position as the Credit scene’s back button?

I just tried removing the sound action but it did nothing, still closing out. Yes there is a close button in the exact same spot in the characters scene. If you are in the characters scene, and click credits, I used the action Change to Scene


Tried it, did not work for me, same problem. Thanks for your response

Did you add it in the first scene?
Alternatively, you can use a timer. So that the button can only be pressed 0.3 seconds after the start of the scene.

I’ve tried using it in both scenes to no avail. How would a timer help? Do you mean a timer in the credits scene? Because I have waited awhile before clicking back, it still closes out.

UPDATE: So if I use ‘Pause and start a new scene’ in “Characters” and ‘Stop the scene and go back to a previous paused one’ in “Credits” the same thing is happening.

The problem is that both buttons are pressed at the same time, although one is in the new scene. Move it to a different position and try again.

It does work if I move it to a new spot in the scene. Thank you.

How does a button in the same spot, on a completely different scene, effect a different button? That makes no sense. If I stop the scene “Characters” and start a new scene “Credits” they should have none of the same events.

I shouldn’t have to move a button from where I want it. Thank you for your help.

Because the scene changes when the mouse is pressed, and in the new scene the mouse is still pressed, bc the scene-change is faster than you can let go of the mouse button.
Use Mouse is released, instead of Mouse is pressed will solve the problem.

1 Like

That works! Will it work on a touch device though?

With the code in my screenshot it should.
Mobile Browser and Mobile App are also not exactly the same in this aspect, try it. :slight_smile:

Will do, Thanks again for all your help!

Using ‘Mouse is Released’ instead of ‘Mouse is Pressed’ worked on touchscreen devices. Nice fix jack!

1 Like