A little issue with the template

Hey i totally changed a template i’am working right now and when i tried to upload it on gd games it appears this error, how i can fix that? As i said, i totally changed every assets and even a part of the code of the template

I dont think you can republish templates as the game you publish is what your own and you own it. But since you dont own the template you cannot republish it on your own.I think you should save the file of the template and then create new project and open the files on the new project and then try to publish that should work since the project is made by you and you own it.Do it and tell me if it works!

isn’t the whole template thing created to let you learn and build a game on the bones of the template? If I change and add part of the code and all the assets I don’t understand why it has to be blocked, unfortunately I can’t simply move everything as if nothing had happened also because the stuff I inserted, the scene setups, the external layouts etc. are so many

Can you send me the modified template of yours I’ll like to see what I can do you can send me through Google drive or any other way you know.

This sounds like the same issue. Important don’t try it on the original copy. Either copy the project folder or save the project into a different folder.


If you’re still running into this after the above, keep in mind you usually cannot upload a template using the same project name nor packaging name as one owned by someone else.

This is also true for exports when you try to upload to the iOS app or google play stores.

Always ensure you update that info in your project settings from the example name (or the project name) as shown on the bottom of this screenshot.

I just changed all the properties, even the publisher name, description, thumbnails, authors, package name, version and all the other parameters, but nothing, maybe i need to change entirely the code? I even removed 90% of the assets

Just tried and it appears this error when i try to create a link if i leave only the quotes, while if i remove the quotes i can’t open anymore the project
The solution is old, maybe they changed something

It could’ve changed or you have a different issue.

Another post had this
Note that you can also clear the line, set it to:
“projectUuid”: “”, then save, and reopen your project with GDevelop. You’ll be able to register again your game online


Ye i exactly did like this and it gave me that error 400

1 Like

I just tried and there isn’t any online tab to unregister the project, maybe you mean the dashboard, to unregister it, but it’s a template i am using and I can’t do it cause i am not the one who made the template

small update, I just tried to manage the project uid string in the file, but I got nothing, I congratulate the Gdevelop team because this way it is almost impossible to steal other people’s projects, but at the same time solve this thing because templates are useful precisely to be reused on the same template​:sob::sob::sob:

Changed the entire code, still the same issue, should i just create a new project at this point? I dont want to re adding everything again