Admob ads not showing

Hey guys i have added my ad mob banner id in the propeties part and also made an event for the admob here is a screen shot of the event.

the ads arent showing on the preview here or on my android i downloaded the apk and put on my android and the game runs smotthly but at the point they should show they are not showing and i set the even to test to see if it would show

any idea why they not showing or am i missing a part on the event ?

In the properties of your game you need write the Id of your App.
Have you see the wiki page ?

You will have to wait a few minutes or a few days for google to verify your account, after that Google will propose ads, during this check time you will have nothing.
You may only have banner ads at first. If you have them you will have the reward video and Interstitial don’t worries.
Think just to use the right Id for each type of ads, and your app Id
Each Id is different.
And turn Off test mode before export in APK.

If you have any doubts about your events look at the Admob example provided with GDevelop, these events are functional.

I’ve tested all types of ads: Banner, Interstitial, Rewarded Video, all work perfectly.

thank you for your reply :slight_smile:

yes ive put my id of app in the property section

and google have verified my account as i other apps using adds from different place , but i though the test add would show straight up on my android but im not getting any ads from it at all thats why i was wondering if my events section is correct

If you have any doubts about your events look at the Admob example provided with GDevelop, these events are functional.

ah just realised i put both as ad id and not the first as app id :confused: my bad lol thank you for the help

ive double and triple checked all my app id is correct in the property section and in event i am using the load event and show loaded acction with testing off but all others yes, downloaded apk, and its still not showing the banners and ive checked my admob and its active showing ads ? you got any advice as ive done the tutorials and the video and checked the game with the event and tried all of them ways and still no ads showing :frowning:

Can you share your sources files and apk ?

still having the same problem if someone could help :slight_smile:

as i see you.mixed 2 events together is loading and loaded.
Which is your code now?

im at this ive tried evey way and nothing is working lol done 5 exports already and nothing

ive tried the load banner and the action if it loads then show with the yes to show ticked that didnt work on test or normal

ok your show banner i think never runs.
Move the load banner to at the beginning of scene
Then move banner is ready event outside beginning of scene

like this ?

yes, that should work

will try it now and let you know

Hello guys i kinda have the same problem. If i use test ads it works perfectly but when i switch to normal mode they won’t show. Any ideas?

Hello! It has been 2 years since the last post in this thread, and you already asked the question as a separate thread already.

Please keep questions to one post, and do not bump multi-year aged threads. It looks like folks are responding to your thread, so I’ll be closing this out.

1 Like