AdMob advertisement does not show!

Hello people! First a good morning / good afternoon or good night! It has already been warned that I am a Brazilian, and my English is not the best, so forgive my mistakes!

I’m developing a game for Android using GDevelop 5 for two months, and for a few weeks, I’ve been facing a problem that I can’t solve, I can’t show ads in my game!

As it will be a cell phone game, I preferred it to be free, and I want to generate revenue through advertisements, the problem is, no matter what I do, the advertisements just don’t work!

I already looked at the articles of Admob following step by step, and still nothing.

I tried to place Reward Videos and Interstitial ads, but none of them worked!!

To make the discussion quicker, I will mention a few things that I have already done

1st: I already configured the Admob application ID in my project, as well as in the image in the link below:

Note: I censored to avoid problems, and I’ve tried to put “/” as requested in GDevelop, and also put “~” as requested in AdMob

2nd: I have also set up the ad ID, in the image on the link below, I will be showing the Reward Video ad, but I have also set up Interstitial ads with your own ID and everything, and both do not work on any cell phone that I tested.

Note: I am using the test mode, so there is no way the problem is my AdMob account, since I am just testing to see if everything is working, and, as the event itself says: "If test mode is set to true a test video will be displayed. "

3rd: I always create my APKs using Cordova, but I already tested using the APK created by GDevelop, and also … no results!

4th: I’ve seen the example project that GDevelop gives to test, and the settings of the example project, with mine, seems to be compatible.

Additional Information:
GDevelop version: GDevelop 5.0.0-beta101 based on GDevelop.js 4.0.98-0-release.
Game platforms: Android only.
APK generation: Cordova (Manually) (I’ve tried it using the GDevelop 5 system)

Then that’s it! Thanks for listening! And if you can help, a double thanks :heart:

I just got ads working in my game today, so I don’t know tons about them but my test ads are actually showing up, so maybe seeing the way i did it will help or give you some ideas :slight_smile: I’ll just include a picture of what I did that resulted in the test ads being shown. Looking at your screencaps, it looks like it should work but I’m a newbie with this stuff so I’m not really sure.

I build my game through GDevelop and open on my phone and the test ads do load and play

1 Like

This is strange, if your test ads are working, mine used also work. Anyway, they still don’t show up, no matter what I do. I’ve tried to redo all procedures, redo all events, and nothing! I’m still unsure of what’s going on.

Anyway, thanks for the reply :smile:

First things todo is to test your admob keys in the admob example provide in GD and compile with the online build service to an APK.

This will told you if your events are wrong, or if you admob account is active or if you manual compile with cordova is wrong.

Hi! Sorry for the delay! I did not receive notification of your reply. Anyway, I will try later.