Android Package is Debuggable - google play doesn't work!

Hi gdevelopers,

I’ve created a standalone android apk.
Like I did 30 times before, for the same project.
using Export project to standalone game: Package for Android

After uploading to Google Play I get the following error:

Upload failed
You uploaded a debuggable APK or Android App Bundle. For security reasons you need to disable debugging before it can be published in Google Play. Find out more about debuggable APKs or Android App Bundles.

You uploaded an APK that is not signed with the upload certificate. You must use the same certificate. The upload certificate has fingerprint:

I got this error once before, then I tried the next day, and everything worked.

No I’m waiting and sending my project to the build server every few hours for a few days, but no success.

What can be the problem? Is the build server just compiling in debug mode?

All help appreciated,

game: Santa, Penguin Hunter (previous version is on play store :slight_smile: )

happened the same to me some days ago, compiled again with GDevelop and google didn’t say anything.
Maybe something went wrong on the previous compilation :confused:
I use export to android option. Are you using Gdevelop 5 beta? I am and maybe was an issue with the version, now I’m with beta 64.


Thanks for your response Xisco!

I’m also using the beta 64 version, so that is probably not the problem :frowning:.
I will check if there’s a new GDevelop version.

And if you have any idea… :slight_smile:


Hi again!!
Last night I had the same problem again, compiled with GDevelop twice and tried several times PhoneGap build, always the same error.
You are right should be a problem from google. The message says something about signature of file, but google is administering my keys to sign files :confused:
I’ll try to contact google, and write here any news.

Hi Xisco,

I’m glad I’m not the only one facing this problem :wink: .
Thanks for updating the post with news.

If I can help in any way… let me know. (but I have to say that this problem is beyond my comfort-zone :smiley: )

Good luck,


I’ve found a possible solution but sounds a bit tricky I’m working on it. In the mean time I mailed google to ask for a solution, I’ll let you know.
the possible solution … =authorize

I did some research and digging so, bad news: google is right.
I found a tool called apktool to decompile the apk and androidmanifest xml contains a section debuggable=true, so I know wkhat google will answer me. I midified the file and packed again with apktool now google says that apk is not sincronized or domething like that :angry: :cry: :angry:
The question here is why gdevelop makes debuggable apks and the same with phonegap builder, maybe has to be with cordova :confused: :confused:

If the error persist please open an issue on GitHub, if the build service is actually building debug apk’s surely it’s just a bad setting and 4ian will fix it in a breeze :slight_smile:

thanks lizard I’ll fill an issue on GitHub as soon as I have a computer atr hand :sunglasses:

just opened git issue last night. I’ve found some info.
I’ve struggled with the issue, found an utility to unpak apk, modified and then packed but then the message from google is that is not well signed, and I don’t have the key to sign it, so I’m stuck until the problem is solved.
Seems that using cordova with --release option make a release apk and not debuggable, maybe is the solution.
I’ve set up cordova but something is not really working, will continue trying in the meantime :angry:

hi, more news.
I’ve tries to compile with android studio but google says that it is not signed with right key.
Google uses the key used in first uploaded apk so I guess it is stored on the cloud compiler gdevelop uses. so i can’t sign it
Options are ( I guess) wait until compiler makes non debiggable apks or ask Google to change key and compile with Android studio

Do you have more news ?

here is github issue
no solution till now and more people having issue. I’ve found a possible solution is on Github, I put it here too but requires manual compilation :open_mouth: … d-key-mac/

google contacted my, they had to check my identity.
Solution is to generate oour own private key and send google our public key, then sign ourselves the apk.
I’m compiling with androidStudio and cordova but admbo doesn’t work, when compiled with gdevelop works but it is debuggable so I’ve found apkeasy tool that allows to decompiile modify and compile again, then I’ll try to sign it.
Waiting for google to accept muy public key, if you want can do a tutorial.

Yes please make a tutorial :smiley:
Thanks a lot for all

I’ll do a tuto when all is working
Google accepted my new upload public key, so i’ll be able to uplpad signed apks in two days time.

Finally found a solution for this problem, this is the easy and short solution :sunglasses: . The long one is to compile by myself and although is working admob don’t work so I stick to the short solution.
Basically you have to decompile the apk, modify, compile again and sign. The problem is singing, because we don’t have the private key, but it is all explained on the PDF.
On this link there is the PDF and some of the needed files. … iSacnJKG3F

Good luck

Hi xisco,

i am facing the same issue and wanted to have your experience, the link is not working, i wonder if you can reshare it.

Thanks :slight_smile: