Animations NOT switching or STUCK while using Yarn dialogues

Hello guys, im trying to make my yarn dialogues work. But I am facing a particular issue. Even though the dialogue works out perfectly, my animation dosent change according to when its supposed to be called.
For example in the screen shot 1 , There is supposed to be a sprite on the left which is supposed to be shown as the dialogue is running. I have also shared my nametag properties, events for the dialogue system, and the yarn dialogue which is being used. (Im able to share 1 screen shot :confused: , i have provided pasteboardd links for the other ss )

Hi at0mO_O. It doesn’t look like pluvia has an animation. It’s just blank, unless there’s something lower down in the screenshot. So you would only see an empty animation when it tries to switch to pluvia.

Check that pluvia has an animation. If that isn’t the issue, it would be good to see the whole text in the first node i.e. double click into the node and screenshot that.

Edit: Also check the nameTag object is in the scene editor. The tutorial events don’t create the object, so it needs to be in the scene to begin with.

Hello , Yes pluvia isnt supposed to have any animation right now. Only lux, but the game is not able to pull even the lux animations. Here is the first node screen shot and pasteboard link for the scene editor.

edit : pasteboard apparently deleted my events screen shot so ill upload it again just in case
Pasteboard - Uploaded Image

Try something for me please: position your nametag object in the middle of your scene, instead of the top left corner and try running your game again.

And also make sure its Z-order is higher than any other art on that layer. Try giving it 10, for example, and see what happens.

Okay I will do that, looks like on the top left but the first animation [ lux ] is placed accordingly so the none nameTag appears a bit on top, none the less, let me try that .

I tried it , but it still it ddint work.

That’s very strange. There is nothing in your screenshots that looks weird. Mine works exactly the same. If the object is on screen and it’s not underneath anything, then I’m really not sure.

One thing: you can’t change a nametag (execute a command) just before an options. You can only change it before a line. So this will work to change the animation:

<< nameTag Jason >>
This is a normal line of dialogue.
[[Let’s do that. |yes]]
[[I don’t feel like it. |no]]

But this is won’t work to change the animation:

<< nameTag Jason >>
[[Let’s do that. |yes]]
[[I don’t feel like it. |no]]

But that doesn’t explain why your command doesn’t seem to be working. Your Yarn dialogue is formatted a little strangely, but that shouldn’t stop the command from working, especially if your dialogue is working fine. Why is there a long ‘. . . . . . . . . . .’ in your dialogue and have you tried removing it? Yarn can be a bit finicky with unusual characters. Did you copy paste from plain text, like Notepad? That’s the best way to avoid weird things happening.

the long … is part of a dialogue. But ill try removing it and check if anything works.I tried, it didnt really work. Do you think is it possible that you could look into my project if I provide you the file. Ofcourse only if that is okay with you.

Have you also tried removing the layer effects? I noticed you have layer effects on both layers. It’s worth trying to disable anything that might be causing issues, even if it seems unlikely. Many times when I work on my game in GDevelop I have found that when I change something in one place, something unexpected might happen in another.

I don’t mind taking a look at your project files. That might not be today, though, but certainly tomorrow. Feel free to share your project and I will take a look. I am confident, though, that if you follow the tutorial exactly and don’t try to customise or alter it as you go, it does work. It’s always best to make it your own after the tutorial rather than during. Then you can be sure what went wrong: the tutorial or you! :smiley:

I dont think its because of the layers effects because its been happening before even applying them.

I had found your twitter, can I share the zip file onto that. This forum is not allowing me to do that here

If Twitter lets you share files, sure, go ahead. Or you can send me a direct message on here. I haven’t used that before, but perhaps it lets you attach files.

I think the forum only lets you share files and post more screenshots when you have been a user for a period of time. I’m not sure how long.

i cant seem to find the message button here on gdevelop forums lol, how do i do it ? im sorry im new to it aaa

I wish I was paid by the hour for this :smiley:

Click on my name in any of my messages and then click the big blue button:

there is no message button for me

Hmmm, there must be limits on that feature because you’re new. How else to send? A google drive share isn’t very good idea because it would be public, though you could delete it 10 minutes later. What about something like WeTransfer or some other file share thing?

I just realised I would need to give my email address for that to work, so I can’t do that - sorry. If you can upload the files to some kind of share service, and give me a link, I can do that.

I have uploaded the file on mediafire,

also thank you for sticking out through this!

Got it! :slight_smile:

I will take a look tomorrow. I’m in the UK and will aim to reply to you by 3pm my time. If you manage to fix it yourself in the meantime, please post a message here and say what was wrong.

gotcha, thank you! Ill be having school tomorrow so please dont mind if I reply a bit late :sweat_smile:

1 Like

Hi at0mO_O.

The action was missing from this:

So I added it:

This is strange because in one of your screenshots I saw that you had done this correctly, but in the project files that you shared with me the event wasn’t complete. So we both spent a lot of time on something very obvious because your screenshot looked fine. Did you accidentally delete the action from this event after you did the screenshot?

I originally wrote a long post about your image size, but that wasn’t the issue after all. It was your incomplete event. However, your Lux image is very large and I would urge you to reduce him down in an image editor and generally be mindful of your image sizes. Here’s the wiki page about image optimisation:

I really like your art :slight_smile: I think your game will have a good atmosphere. Good luck with the project.

Hi at0mO_O. Please see the amended comment above. Image size wasn’t the issue after all. (posting this in case you saw the original message in an email and didn’t check back here to see the amended comment)

Hello worried pixels, first alot , Thanks alot, secondly sorry for bothering you for such a silly mistake! But I do realize that Image size does play a role. For example, I have completed the pluvia sprite, and when I put it in the game, everything broke again. But I realized that i forgot to scale it down. When I scaled the resolution of pluvia sprite down, everything worked perfectly. Thanks for your time! Good luck on your ongoing projects as well! :slight_smile:

1 Like